Subject: [alpine-devel] vim fix and/or change

From: Milan P. Stanić <[email-masked]>
Date: Tue, 23 Apr 2019 18:55:19 +0200

Hi,

Vim in current state in edge is somewhat problematic because vimdiff
subpackage depends on gvim (which is subpackage of vim) and gvim
conflicts with vim through 'provides"vim"' option.

I fixed this in my local build, but after looking at the current status
I think that vim needs a little more work.

My thoughts are about these:
Make vim-runtime subpackage with runtime files which is shared by vim
and gvim and set these to depend on vim-runtime.

Make small vim package (vim-basic, vim-tiny) which doesn't depends on
vim-runtime and 'conflicts' with vim and gvim.

Make vimdiff which depends on vim or gvim, and on diffutils.

Does this make sense or just fix vimdiff dependency on gvim is enough?

-- 
regards

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Drew DeVault <[email-masked]>
Date: Tue, 23 Apr 2019 16:03:53 -0400

Hm, the vimdiff subpackage definitely does not depend on gvim.

---

---

From: Milan P. Stanić <[email-masked]>
Date: Tue, 23 Apr 2019 22:46:40 +0200

> Hm, the vimdiff subpackage definitely does not depend on gvim.
edge:~/ > apk info -R vimdiff
vimdiff-8.1.1075-r0 depends on:
diffutils
gvim=8.1.1075-r0
vim=8.1.1075-r0

and:

edge:~/ > sudo apk add vimdiff
ERROR: unsatisfiable constraints:
  gvim-8.1.1075-r0:
    breaks: vimdiff-8.1.1075-r0[vim=8.1.1075-r0]
    satisfies: world[vim] vimdiff-8.1.1075-r0[gvim=8.1.1075-r0]

---

---

From: Drew DeVault <[email-masked]>
Date: Tue, 23 Apr 2019 16:50:42 -0400

I can reproduce this apk add error, but the APKBUILD looks correct to
me. Can anyone see what I'm missing?

---

---

From: Milan P. Stanić <[email-masked]>
Date: Tue, 23 Apr 2019 22:57:24 +0200

> me. Can anyone see what I'm missing?

Attached is fixed (to some degree) APKBUILD.