Subject: apk-tools release imminent

From: Timo Teras <[email-masked]>
Date: Mon, 24 Aug 2020 13:55:24 +0300

Hi all,

There's a good amount of things piled up in the current apk-tools
master branch:
 - addition of manual pages
 - auto generation of help from manual pages
 - reworking of options parsing
 - upgrade named packages and --ignore
 - some refactoring of the io framework
 - lua updated to 5.3
 - humanization of size output (kB/MB/GB suffix)
 - deprecation of the old/original apk package format
 - various bug fixes

I am still going to fix some minor issues in the new 'upgrade'
functionality.

But I expect to tag 2.12 (_rc1) soon, and upgrade aports. If you can do
early testing from the git master, that's appreciated.

After this, I hope to get back on track to work on the apk version 3
features.

Cheers,
Timo

---

From: Ariadne Conill <[email-masked]>
Date: Mon, 24 Aug 2020 05:10:41 -0600

Hello,

> early testing from the git master, that's appreciated.

Great!  I am already using git master to manage my system, it works fine 
so far.

> After this, I hope to get back on track to work on the apk version 3

I can't wait to dive into apk-tools v3 work.

Ariadne