Subject: Re: alpine is not support mips64el platform on apk packages source

From: Ariadne Conill <[email-masked]>
Date: Tue, 21 Apr 2020 03:40:10 -0600

Hello,

On Tuesday, April 21, 2020 3:24:28 AM MDT 刘小东 wrote:
> Hi,
> 
> I am a developer from Loongson company (R & D CPU/mip64el). I really need
> help from the community.

I am the person doing primary coordination of the mips ports in Alpine.

> In order to meet the needs of our customers for alpine docker images, we 
> have made alpine docker images version 3.9 successfully based on community
> source code. We need to make official images  to solve this
> problemfundamentally, but the difficult is lack of apk package on mips64el
> platform. We want to cooperates  with our alpine community  to develop the
> alpine linux ecosystem on the mips64el platform. We can provide maintenance
> and anything community needs to prosper the mips64el platform ecology.

Many packages have already been adapted for mips64el, but we have not
done a mips64el build.  We are interested in supporting both mips64 and
mips64el on Alpine, as well as mips/mipsel.  We are not presently interested
in mips64r6 or mips32r6, as they use different bytecode.

We are *especially* interested in supporting Loongson on mips64el, but
it is not so easy for us to acquire hardware to test with.  Our builders are
based on 16-core Cavium Octeon3 CPUs at present, but it would be nice
to have some Loongson hardware in the mix as well.

The main blocker for Docker right now is that several dependencies of
Docker assume that mips is 32-bit O32 ABI.  We are working on solving
these dependencies so we can begin producing Docker images and
enabling CI.

Your help with this would be appreciated, as well as a reliable source of
Loongson hardware.  Those are the main things we would need to be
able to support Loongson effectively in Alpine.

Thanks,
Ariadne

---

From: 刘小东 <[email-masked]>
Date: Wed, 22 Apr 2020 10:09:19 +0800 (GMT+08:00)

Hi Ariadne，

I am very glad to receive your reply, thanks very much.
We are willing donate Loongson machines to alpine community and we have donated machines to the community which make docker official images. Please list the specification of machine you need，tell us the donation process and mailing address.
The kernel built by the community's raw code cannot be run directly on our machine, because some of our patches have not been submitted to the community. We can preset 4.19 kernel binaries for you. Please tell me any requirements for the operating system software and version, we will do our best to meet you.
In addition, we have docker-ce 18.06 and alpine docker images version 3.9 and some apk packages, which might be provided to you for enabling CI.

Thanks!

&gt; -----原始邮件-----
&gt; 发件人: "Ariadne Conill" <[email-masked]>
&gt; 发送时间: 2020-04-21 17:40:10 (星期二)
&gt; 收件人: ~alpine/[email-masked]
&gt; 抄送: "王洪虎" <[email-masked]>, "王怀卿" <[email-masked]>, "汪雷" <[email-masked]>, "王铭" <[email-masked]>, "黄佳文" <[email-masked]>, "侯芳东" <[email-masked]>, "杜川" <[email-masked]>, "刘小东" <[email-masked]>
&gt; 主题: Re: alpine is not support mips64el platform on apk packages source
&gt; 
&gt; Hello,
&gt; 
&gt; On Tuesday, April 21, 2020 3:24:28 AM MDT 刘小东 wrote:
&gt; &gt; Hi,
&gt; &gt; 
&gt; &gt; I am a developer from Loongson company (R &amp; D CPU/mip64el). I really need
&gt; &gt; help from the community.
&gt; 
&gt; I am the person doing primary coordination of the mips ports in Alpine.
&gt; 
&gt; &gt; In order to meet the needs of our customers for alpine docker images, we 
&gt; &gt; have made alpine docker images version 3.9 successfully based on community
&gt; &gt; source code. We need to make official images  to solve this
&gt; &gt; problemfundamentally, but the difficult is lack of apk package on mips64el
&gt; &gt; platform. We want to cooperates  with our alpine community  to develop the
&gt; &gt; alpine linux ecosystem on the mips64el platform. We can provide maintenance
&gt; &gt; and anything community needs to prosper the mips64el platform ecology.
&gt; 
&gt; Many packages have already been adapted for mips64el, but we have not
&gt; done a mips64el build.  We are interested in supporting both mips64 and
&gt; mips64el on Alpine, as well as mips/mipsel.  We are not presently interested
&gt; in mips64r6 or mips32r6, as they use different bytecode.
&gt; 
&gt; We are *especially* interested in supporting Loongson on mips64el, but
&gt; it is not so easy for us to acquire hardware to test with.  Our builders are
&gt; based on 16-core Cavium Octeon3 CPUs at present, but it would be nice
&gt; to have some Loongson hardware in the mix as well.
&gt; 
&gt; The main blocker for Docker right now is that several dependencies of
&gt; Docker assume that mips is 32-bit O32 ABI.  We are working on solving
&gt; these dependencies so we can begin producing Docker images and
&gt; enabling CI.
&gt; 
&gt; Your help with this would be appreciated, as well as a reliable source of
&gt; Loongson hardware.  Those are the main things we would need to be
&gt; able to support Loongson effectively in Alpine.
&gt; 
&gt; Thanks,
&gt; Ariadne
&gt;

------------------------------
--

刘小东
龙芯中科技术有限公司 系统研发部
-----
北京市海淀区北清路中关村环保科技示范园 龙芯产业园 100095
电话:  
传真: 
邮箱: [email-masked]
公司网址: www.loongson.cn</[email-masked]></[email-masked]></[email-masked]></[email-masked]></[email-masked]></[email-masked]></[email-masked]></[email-masked]></[email-masked]>

---

From: Ariadne Conill <[email-masked]>
Date: Wed, 22 Apr 2020 09:08:52 -0600

Hello,

On Tuesday, April 21, 2020 8:09:19 PM MDT 刘小东 wrote:
> We are willing donate Loongson machines to alpine community and we have
> donated machines to the community which make docker official images. Please
> list the specification of machine you need，tell us the donation process and
> mailing address.

Regarding coordination of the Loongson build hardware, we will need to sit 
down and figure out who would be the best person to handle maintaining it.  
Please stay tuned on that, we will get back to you.

> The kernel built by the community's raw code cannot be run
> directly on our machine, because some of our patches have not been
> submitted to the community.

We would prefer to have patches, so that we can build official Alpine kernels 
for Loongson based on current sources.

> We can preset 4.19 kernel binaries for you.

Right now our Octeon3 builders are running on a 4.9 kernel provided by Cavium.  
We can do the same with Loongson for now, but for the port to be truly viable 
in the long-term we would need to get these patches upstreamed as quickly as 
possible.  The Alpine community can help with this by providing feedback on 
the kernel patches to you and also to upstream kernel developers as you submit 
them, since we can verify that the patches have been tested on real hardware 
by us.

> Please tell me any requirements for the operating system software and
> version, we will do our best to meet you. In addition, we have docker-ce
> 18.06 and alpine docker images version 3.9 and some apk packages, which
> might be provided to you for enabling CI.

I think the main goal right now would be to bootstrap mips64el.  Then we can 
install the image on Loongson hardware from there.  This is something I can 
work on after 3.12 release is done.  Sound good?

Thanks,

Ariadne

---

From: 刘小东 <[email-masked]>
Date: Thu, 23 Apr 2020 15:30:39 +0800 (GMT+08:00)

Hi Ariadne，

&gt; Regarding coordination of the Loongson build hardware, we will need to sit 
&gt; down and figure out who would be the best person to handle maintaining it.  
&gt; Please stay tuned on that, we will get back to you.

We are willing to maintain or contribute on mips64el. We will follow this issue.

&gt; We would prefer to have patches, so that we can build official Alpine kernels 
&gt; for Loongson based on current sources.

We have no version 4.9 kernel, alternative kernel 4.19 or 5.4 is OK? 
  
&gt; Right now our Octeon3 builders are running on a 4.9 kernel provided by Cavium.  
&gt; We can do the same with Loongson for now, but for the port to be truly viable 
&gt; in the long-term we would need to get these patches upstreamed as quickly as 
&gt; possible.  The Alpine community can help with this by providing feedback on 
&gt; the kernel patches to you and also to upstream kernel developers as you submit 
&gt; them, since we can verify that the patches have been tested on real hardware 
&gt; by us.

Thanks very much for your kind mind on kernel patches. 

&gt; I think the main goal right now would be to bootstrap mips64el.  Then we can 
&gt; install the image on Loongson hardware from there.  This is something I can 
&gt; work on after 3.12 release is done.  Sound good? 

We agree with your plan. Our goals are the same on a certain degree.
 
Thanks,

Liu Xiaodong