Subject: alpine is not support mips64el platform on apk packages source

From: 刘小东 <[email-masked]>
Date: Sun, 26 Apr 2020 15:59:21 +0800 (GMT+08:00)

Hi Ariadne,

I have notified your requirements to our kernel team, but there are some issues as follows:
 * Can you accept patches that we have not submitted to the Linux community yet? Or only accept patches from upstream? 
 * We do have difficulties to provide kernel version 4.9, alternative kernel version 4.19 and 5.4 are OK? 

Compared with Cavium's Octeon3, our cpu performance is very competitive. We can currently provide the following machines:
(Loongson-3A3000) 1.5GHz 4/8/16 core      DDR3
(Loongson-3A4000) 1.8-2.0GHz 4/8/16 core  DDR4

We are very willing to participate in alpine community and establish long-term cooperative relationship with the community.
And what rules need to learn before contributing to the community?
We do want to take on community tasks as soon as possible, where can we get tasts?

Sincerely!

Liu Xiaodong

--

刘小东
龙芯中科技术有限公司 系统研发部
-----
北京市海淀区北清路中关村环保科技示范园 龙芯产业园 100095
电话: 
传真:
邮箱: [email-masked]
公司网址: www.loongson.cn

---

From: Ariadne Conill <[email-masked]>
Date: Wed, 29 Apr 2020 21:55:03 -0600

Hi,

On Sunday, April 26, 2020 1:59:21 AM MDT 刘小东 wrote:
> Hi Ariadne,
> 
> I have notified your requirements to our kernel team, but there are some
> issues as follows: * Can you accept patches that we have not submitted to
> the Linux community yet? Or only accept patches from upstream? * We do have
> difficulties to provide kernel version 4.9, alternative kernel version 4.19
> and 5.4 are OK?

We would prefer patches for 5.4, and we can probably carry them in our linux-
lts package, but we should make sure that Natanael is okay with that as he 
leads kernel maintenance in Alpine.  Otherwise, we can provide a patched 
kernel as we do with linux-octeon.

> Compared with Cavium's Octeon3, our cpu performance is very competitive. We
> can currently provide the following machines: (Loongson-3A3000) 1.5GHz
> 4/8/16 core      DDR3
> We are very willing to participate in alpine community and establish
> long-term cooperative relationship with the community. And what rules need
> to learn before contributing to the community?

No need to learn anything, just start sending us patches, I will talk with the 
infra team and other mips porters to see if there is any interested parties in 
maintaining the build hardware for mips64el.  Once we have a plan on that 
front, we can talk about hardware.  Or Loongson could maintain the builder if 
that is more interesting. :)

> We do want to take on community tasks as soon as possible, where can we get 

Right now, we are in temporary feature freeze as we prepare to branch the 3.12 
release.  My suggestion as an initial starting point would be to submit a 
mips64el profile for linux-lts that supports booting on Loongson hardware.  
This is something that could be merged during feature freeze as it does not 
have any practical impact on the release.

My thoughts are that we should have Loongson as the primary focus of mips64el 
and Octeon as the primary focus of mips64, as I believe Loongson does not 
support big endian operation.  If I am wrong, it may be nice to support both 
Octeon and Loongson in these configurations.

I would be happy to review and push the kernel change as a starting point, 
feel free to tag me in gitlab (my username is @kaniini).

Ariadne

---

From: Natanael Copa <[email-masked]>
Date: Thu, 30 Apr 2020 16:37:18 +0200

On Wed, 29 Apr 2020 21:55:03 -0600
Ariadne Conill <[email-masked]> wrote:

> Hi,
> 
> On Sunday, April 26, 2020 1:59:21 AM MDT *** wrote:
> > Hi Ariadne,
> > 

Depends a bit on how intrusive they are and how much they get in the
way when upstream kernel is updated. I don't want spend hours of
rebasing kernel patches on every kernel update.

-nc

---

From: 刘小东 <[email-masked]>
Date: Fri, 8 May 2020 15:51:11 +0800 (GMT+08:00)

Hi, 

Labour Day holiday just ended, I am writing to you. Thank you very much for your timely reply.

We continue to discuss the kernel pathes issue,

Our original issues: 
I have notified your requirements to our kernel team, but there are some issues as follows: 
 (1)Can you accept patches that we have not submitted to the Linux community yet? Or only accept patches from upstream? 
 (2)We do have difficulties to provide kernel version 4.9, alternative kernel version 4.19 and 5.4 are OK?

Ariadne reply: 

Natanael reply:

Therefore, we reached some consensuses:
You can accept patches that we have not submitted to the Linux community, but our patches must meet your requirements as Natanael raised.

Based on these consensuses, We will try our best to meet Natanael's requirements.
(1)The intrusiveness of the patches is difficult to measure, we can firstly submit patches( based on kernel version 5.4) to you for review and modify them according to your suggestions.
(2)When upstream kernel is updated, we will actively submit patches from upstream to the alpine community. 
(3)Our kernel is very stable, and the update range and frequency are very small. 
(4)Near the Linux community kernel version 5.7, our patches all should be able to merge into the master branch.

Other issue,

Ariadne reply: 

Hi Ariadne, your understanding is very correct, Loongson does not support big endian operation.

Thanks!

Liu Xiaodong

---

From: 刘小东 <[email-masked]>
Date: Fri, 8 May 2020 15:57:55 +0800 (GMT+08:00)

Hi, 

We continue to discuss the kernel patches issue,

Our original issues: 

Ariadne reply: 

Natanael reply:

Other issue,

Ariadne reply: 

Thanks!

Liu Xiaodong