Subject: [alpine-devel] Re: Dangerous build configuration in Alpine Linux port of MongoDB

From: Marc Vertes <[email-masked]>
Date: Wed, 18 Apr 2018 22:42:49 +0200

Hi Ramon,

Thanks for reaching this issue. For your information, I've already submitted a patch yesterday to alpine maintainers to fix the "cache_cursors" issue, and at least fix the starting problem of 3.6.4, but I agree with you it may be lucky case and offers no strong warranty for future release.

I will follow your advice, and propose a change of the APK to build against the wiredtiger tree provided by mongodb source.

I'm forwarding to alpine dev mailing list as well to let other alpine maintainers be aware of the situation,

Thanks again

Regards,
Marc

> Le 18 avr. 2018 à 21:46, Ramon Fernandez <[email-masked]> a écrit :
> 
> Hi Filipp, Marc,
> 
> my name is Ramón, and I work at MongoDB. Recently a user of the Alpine port of MongoDB run into a problem using the 3.6.4 version, and after inspecting the APKBUILD file we’ve seen that it uses the "--use-system-wiredtiger” build option.
> 
> Building MongoDB with a WiredTiger library other than the one included in the MongoDB source tree is not only unsupported, but extremely dangerous — each patch version of MongoDB is tailored to a specific WiredTiger tree. Any other configuration is untested and can lead to undefined behavior, which for a database is a dangerous thing. We’ve discussed this publicly before with a RedHat maintainer.
> 
> The issue we’ve seen is that MongoDB 3.6.4 introduces a new configuration options, “cache_cursors”, which is not part of any existing WiredTiger release. This will cause the Alpine Linux port of MongoDB 3.6.4 to fail with an error at startup. This is the lucky case — this version mismatch can lead to much worse outcomes.
> 
> I’d strongly encourage you to address this issue promptly. I’ll be happy to open a bug report if necessary, but I figured I’d contact you first directly to see if you have any questions on the matter.
> 
> Regards,
> Ramón.
> 

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Ramon Fernandez <[email-masked]>
Date: Wed, 18 Apr 2018 17:33:02 -0400

Thanks for the prompt response Marc, and for forwarding this to the right
place! Feel free to reach out if there are any further questions about this
issue.

Cheers,
Ramón.

On Wed, Apr 18, 2018 at 4:42 PM, Marc Vertes <[email-masked]> wrote:

> Hi Ramon,
>
> Thanks for reaching this issue. For your information, I've already
> submitted a patch yesterday to alpine maintainers to fix the
> "cache_cursors" issue, and at least fix the starting problem of 3.6.4, but
> I agree with you it may be lucky case and offers no strong warranty for
> future release.
>
> I will follow your advice, and propose a change of the APK to build
> against the wiredtiger tree provided by mongodb source.
>
> > my name is Ramón, and I work at MongoDB. Recently a user of the Alpine
> port of MongoDB run into a problem using the 3.6.4 version, and after
> inspecting the APKBUILD file we’ve seen that it uses the
> "--use-system-wiredtiger” build option.
> >
> > Building MongoDB with a WiredTiger library other than the one included
> in the MongoDB source tree is not only unsupported, but extremely dangerous
> — each patch version of MongoDB is tailored to a specific WiredTiger tree.
> Any other configuration is untested and can lead to undefined behavior,
> which for a database is a dangerous thing. We’ve discussed this publicly
> before with a RedHat maintainer.
> >
> > The issue we’ve seen is that MongoDB 3.6.4 introduces a new
> configuration options, “cache_cursors”, which is not part of any existing
> WiredTiger release. This will cause the Alpine Linux port of MongoDB 3.6.4
> to fail with an error at startup. This is the lucky case — this version
> mismatch can lead to much worse outcomes.
> >
> > I’d strongly encourage you to address this issue promptly. I’ll be happy
> to open a bug report if necessary, but I figured I’d contact you first
> directly to see if you have any questions on the matter.
> >
> > Regards,
> > Ramón.
> >
>
>