Subject: [alpine-devel] [PATCH] testing/shadowvpn new aport

From: Ersi Ni <[email-masked]>
Date: Thu, 14 Apr 2016 08:53:47 +0100

Hi all,
shadowvpn is a stateless VPN based on libsodium, originally developed by clowwindy, designed to run on low end devices with features like hiding traffic signature (handshake + packet length) from censoring system, fast and secure by libsodium, stateless + udp makes disruption by packet drop / delay harder. etc. 

This package is intended to ease the deployment of docker based customized VPN solution, e.g. 

    FROM alpine:latest
    RUN apk add --no-cache shadowvpn
    ENTRYPOINT ["shadowvpn"]

---

From: Bela Berde <[email-masked]>
Date: Thu, 14 Apr 2016 10:26:26 +0200

Hi,
Is Bazel available on Alpine?
Thanks

Sent from my iPhone

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Thu, 21 Apr 2016 08:54:54 +0200

On Thu, 14 Apr 2016 10:26:26 +0200

> Is Bazel available on Alpine?

https://pkgs.alpinelinux.org/packages?name=bazel

-nc

---

---

From: Shiz <[email-masked]>
Date: Thu, 21 Apr 2016 16:11:45 +0200

> On 21 Apr 2016, at 08:54, Natanael Copa <[email-masked]> wrote:
> 

pkgs.alpinelinux.org has been broken for almost a week...[1]

- Shiz

[1]: https://pkgs.alpinelinux.org/packages?name=%25gcc%25&branch=&repo=&arch=&maintainer=

---

---

From: Natanael Copa <[email-masked]>
Date: Fri, 22 Apr 2016 12:40:51 +0200

On Thu, 21 Apr 2016 16:11:45 +0200

> [1]: https://pkgs.alpinelinux.org/packages?name=%25gcc%25&branch=&repo=&arch=&maintainer=

Seems like syntax changed:
https://pkgs.alpinelinux.org/packages?name=gcc*&branch=&repo=&arch=&maintainer=

---

---

From: Ersi Ni <[email-masked]>
Date: Tue, 19 Apr 2016 19:52:40 +0100

Hi,

I've amended previous patch to include a dependency 'iptables' and disabled
static binary because it's using alpine's libsodium-dev anyway. Please use
amended patch as attached here. Sorry for inconveniences.

On Thu, Apr 14, 2016 at 8:53 AM, Ersi Ni <[email-masked]> wrote:

> Hi all,
> shadowvpn is a stateless VPN based on libsodium, originally developed by
> clowwindy, designed to run on low end devices with features like hiding
> traffic signature (handshake + packet length) from censoring system, fast
> and secure by libsodium, stateless + udp makes disruption by packet drop /
> delay harder. etc.
>