Subject: [alpine-devel] pingu init.d script patch

From: Ted Trask <[email-masked]>
Date: Wed, 25 Feb 2009 10:06:11 -0800 (PST)

Please patch the pingu aport as follows.  Thanks.

Ted

diff --git a/extra/pingu/pingu.initd b/extra/pingu/pingu.initd
index 7da89c1..39301f8 100644
--- a/extra/pingu/pingu.initd
+++ b/extra/pingu/pingu.initd
@@ -3,7 +3,7 @@
 # Sample init.d file for alpine linux.
 NAME=pingu
-DAEMON=/usr/sbin/$NAME
+DAEMON=/usr/bin/$NAME
 depend() {
        need net
@@ -13,7 +13,7 @@ start() {
        ebegin "Starting ${NAME}"
                start-stop-daemon --start --quiet \
                        --pidfile /var/run/${NAME}.pid \
-                       --exec ${DAEMON} --
+                       --exec ${DAEMON} -- -d
        eend $?
 }

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Thu, 26 Feb 2009 16:20:09 +0100

> Please patch the pingu aport as follows.  Thanks.

Fixed for both 1.8.1 and for the 1.9.x tree.

Thanks!

-nc

---