Subject: [alpine-devel] Ipset lost after rollback ....

From: Harry Lachanas <[email-masked]>
Date: Mon, 16 Feb 2009 09:42:16 +0200

I've just found out that ipset support ( which unfortunately  was 
included in xtables-addons ) was removed since,
1.7.29.1.

Is there any way around this problem ???

I found ipset most useful  after  having  it  there for  2-3  months.

Thanks.
Harry.

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Mon, 16 Feb 2009 10:35:56 +0100

> included in xtables-addons ) was removed since,

xtables-addons was removed due to the ipp2p module not working at all.
So it looks like i forgot to add the ipset package afterwards.

sorry. my mistake.

> I found ipset most useful  after  having  it  there for  2-3  months.

I think the longtime soultion is to make xtables-addons work properly.
Right now I'm focusing on the 1.9 series which has a new (much lighter)
build environment and new apk-tools (written in C)

Looks like have come out with an 1.9 release. I'll try build it for
alpine-1.9.0_alpha2 and test if the ipp2p is working.

Thanks!

-nc

---

---

From: Natanael Copa <[email-masked]>
Date: Mon, 02 Mar 2009 18:08:07 +0100

> I found ipset most useful  after  having  it  there for  2-3  months.

Should be back in xtables-addons in the just released 1.8.1_beta2. 

Care to test if it works?

Thanks!

-nc

---

---

From: Harry Lachanas <[email-masked]>
Date: Tue, 03 Mar 2009 09:00:00 +0200

> Care to test if it works?
Sorry I'm  late,
I was a bit busy..
I am on it right now actually ...
Late today you should have an answer.
Cheers

Harry.

---

---

From: Harry Lachanas <[email-masked]>
Date: Tue, 03 Mar 2009 13:46:37 +0200

>> Care to test if it works?
At a first glance I don't seem to be able to make ipset work

Even though ipset itself seems to work
iptables does'nt seem to be able to use sets.

I've just found out ...!!

xtables-addons 1.10 requirements

 Supported configurations for this release
=========================================

        * iptables >= 1.4.1
          upper bound: iptables <= 1.4.3-rc1

Thanks,

Sorry for being late ,

Harry

---

---

From: Natanael Copa <[email-masked]>
Date: Tue, 03 Mar 2009 13:09:47 +0100

>  Supported configurations for this release

oh.. i forgot iptables. good catch! ok.. thats why we do beta releases.

could you please try:

apk_add -s -u http://dev.alpinelinux.org/~ncopa/alpine/iptables-1.4.2-r2.apk

and se if things work?

thanks alot for testing this!

> Sorry for being late ,

np. no stress. we will not release til we have got those things tested
anyway.

Thanks!

-nc 

---

---

From: Harry Lachanas <[email-masked]>
Date: Tue, 03 Mar 2009 14:36:15 +0200

> apk_add -s -u http://dev.alpinelinux.org/~ncopa/alpine/iptables-1.4.2-r2.apk
That did it !
xtables ipset and iptables-1.4.2 work ok.

I'll set up a test case for ipp2p traffic in a sec ...... ( or more ) ...
and I'll get back to U soon ....

Harry

---

---

From: Natanael Copa <[email-masked]>
Date: Tue, 03 Mar 2009 13:44:00 +0100

> and I'll get back to U soon ....

Thanks alot!

-nc

---

---

From: Harry Lachanas <[email-masked]>
Date: Tue, 03 Mar 2009 16:35:31 +0200

>> and I'll get back to U soon ....
Nc
In my test env

I think its fine ....

It detects ipp2p packets ( bit  ) just fine ...

here is my iptables -nvL

pkts bytes target     prot opt in     out     source               
destination
   25  2464 reject     tcp  --  *      *       0.0.0.0/0            
0.0.0.0/0           state ESTABLISHED --bit

Cheers,
Harry.

---

---

From: Natanael Copa <[email-masked]>
Date: Tue, 03 Mar 2009 15:54:21 +0100

> 0.0.0.0/0           state ESTABLISHED --bit

Wonderful!

Thanks alot!

-nc

---

---

From: Natanael Copa <[email-masked]>
Date: Thu, 26 Feb 2009 20:29:52 +0100

> I found ipset most useful  after  having  it  there for  2-3  months.

FYI, I'm giving xtables a new chance for a stable alpine release 1.8.1.

Please try the beta1 that I'm uploading as I write.

-nc

---