Subject: [alpine-devel] abuild ideas

From: Harry Lachanas <[email-masked]>
Date: Sat, 07 Mar 2009 08:54:51 +0200

Hi all,

I finally managed to have a working 1.9.x sdk env and play a bit with it ...

I got into compiling beecrypt to find out that the sdk was missing the 
g++ package.

Wouldn't be nice if APKBUILD included a "requires" field  specifying  
what short of essential stuff is needed in the sdk to build the package ??

I don't know if I am barking under the wrong tree here, so I've just 
dropped  my "skepsis" on the list.
Thanks.

Cheers,

Harry

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Mon, 09 Mar 2009 11:08:15 +0100

> what short of essential stuff is needed in the sdk to build the package ??

We have makedepends for that.

hum.
You are right. beecrypt is broken. I will have a look at that later.

Thanks!

-nc

---