Subject: [alpine-devel] Alpine 1.9.0_alpha4 call trace

From: aalatchm <[email-masked]>
Date: Thu, 19 Mar 2009 17:37:08 +0000

Alpine-devel:

Using Alpine 1.9.0_alpha4 booting from USB, I used the modified 
syslinux.cfg file shown below. These syslinux.cfg modifications worked 
fine with Alpine 1.7.x, 1.8.x (I also removed 'quiet' to give you more 
output). Note that I found a workaround: uncomment the ttyS0 line in 
/etc/inittab and lbu commit it (I don't think that worked with Alpine 
1.8.x and earlier, but I'm not sure).

----start syslinux.cfg---
serial 0 9600
timeout 20
prompt 1
default grsec
label grsec
       kernel /boot/grsec
       append initrd=/boot/grsec.gz alpine_dev=sda1:vfat 
modules=usb-storage,sd-mod console=tty1,38400 console=ttyS0,9600
----end syslinux.cfg---

See call trace below.

-aalatchm
-- 

SYSLINUX 3.72 2008-09-25  Copyright (C) 1994-2008 H. Peter Anvin
boot:
Loading /boot/grsec........................
Loading 
/boot/grsec.gz..........................................................
.............ready.
BIOS EBDA/lowmem at: 0009f800/0009f800
Linux version 2.6.28.7-grsec (root@nclab01) (gcc version 4.3.3 (GCC) ) 
#1 SMP Tue Mar 3 06:32:31 UTC 2009
KERNEL supported cpus:
 Intel GenuineIntel
 AMD AuthenticAMD
 NSC Geode by NSC
 Cyrix CyrixInstead
 Centaur CentaurHauls
 Transmeta GenuineTMx86
 Transmeta TransmetaCPU
 UMC UMC UMC UMC
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009f800 (usable)
BIOS-e820: 000000000009f800 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000003eee0000 (usable)
BIOS-e820: 000000003eee0000 - 000000003eee3000 (ACPI NVS)
BIOS-e820: 000000003eee3000 - 000000003eef0000 (ACPI data)
BIOS-e820: 000000003eef0000 - 000000003ef00000 (reserved)
BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
DMI 2.3 present.
Phoenix BIOS detected: BIOS may corrupt low RAM, working it around.
last_pfn = 0x3eee0 max_arch_pfn = 0x100000
RAMDISK: 3ea9e000 - 3eedefe7
Allocated new RAMDISK: 00ab2000 - 00ef2fe7
Move RAMDISK from 000000003ea9e000 - 000000003eedefe6 to 00ab2000 - 
00ef2fe6
ACPI: RSDP 000F7E10, 0014 (r0 CN700 )
ACPI: RSDT 3EEE3000, 0034 (r1 CN700  AWRDACPI 42302E31 AWRD        0)
ACPI: FACP 3EEE3080, 0074 (r1 CN700  AWRDACPI 42302E31 AWRD        0)
ACPI: DSDT 3EEE3100, 63D9 (r1 CN700  AWRDACPI     1000 MSFT  3000000)
ACPI: FACS 3EEE0000, 0040
ACPI: _HPT 3EEE9580, 0038 (r1 CN700  AWRDACPI 42302E31 AWRD       98)
ACPI: _WDT 3EEE95C0, 0047 (r1 CN700  AWRDACPI 42302E31 AWRD        0)
ACPI: APIC 3EEE9500, 005A (r1 CN700  AWRDACPI 42302E31 AWRD        0)
118MB HIGHMEM available.
887MB LOWMEM available.
 mapped low ram: 0 - 377fe000
 low ram: 00000000 - 377fe000
 bootmap 00012000 - 00018f00
(9 early reservations) ==> bootmem [0000000000 - 00377fe000]
 #0 [0000000000 - 0000001000]   BIOS data page ==> [0000000000 - 
0000001000]
 #1 [0000001000 - 0000002000]    EX TRAMPOLINE ==> [0000001000 - 
0000002000]
 #2 [0000006000 - 0000007000]       TRAMPOLINE ==> [0000006000 - 
0000007000]
 #3 [0000100000 - 0000aad130]    TEXT DATA BSS ==> [0000100000 - 
0000aad130]
 #4 [0000aae000 - 0000ab2000]    INIT_PG_TABLE ==> [0000aae000 - 
0000ab2000]
 #5 [000009f800 - 0000100000]    BIOS reserved ==> [000009f800 - 
0000100000]
 #6 [0000010000 - 0000012000]          PGTABLE ==> [0000010000 - 
0000012000]
 #7 [0000ab2000 - 0000ef2fe7]      NEW RAMDISK ==> [0000ab2000 - 
0000ef2fe7]
 #8 [0000012000 - 0000019000]          BOOTMAP ==> [0000012000 - 
0000019000]
found SMP MP-table at [c00f3c60] 000f3c60
Zone PFN ranges:
 DMA      0x00000010 -> 0x00001000
 Normal   0x00001000 -> 0x000377fe
 HighMem  0x000377fe -> 0x0003eee0
Movable zone start PFN for each node
early_node_map[2] active PFN ranges
   0: 0x00000010 -> 0x0000009f
   0: 0x00000100 -> 0x0003eee0
ACPI: PM-Timer IO Port: 0x408
ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
ACPI: IOAPIC (id[0x02] address[0xfec00000] gsi_base[0])
IOAPIC[0]: apic_id 2, version 3, address 0xfec00000, GSI 0-23
ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 low level)
Enabling APIC mode:  Flat.  Using 1 I/O APICs
Using ACPI (MADT) for SMP configuration information
SMP: Allowing 1 CPUs, 0 hotplug CPUs
Allocating PCI resources starting at 40000000 (gap: 3ef00000:bfd00000)
PERCPU: Allocating 24576 bytes of per cpu data
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 255633
Kernel command line: initrd=/boot/grsec.gz alpine_dev=sda1:vfat 
modules=usb-stor
age,sd-mod console=tty1,38400 console=ttyS0,9600 BOOT_IMAGE=/boot/grsec
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Initializing CPU#0
PID hash table entries: 4096 (order: 12, 16384 bytes)
Fast TSC calibration using PIT
Detected 1199.934 MHz processor.
Console: colour VGA+ 80x25
console [tty1] enabled
console [ttyS0] enabled
Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
Memory: 1007036k/1031040k available (1686k kernel code, 23212k reserved, 
280k data, 7144k init, 121736k highmem)
virtual kernel memory layout:
   fixmap  : 0xfff47000 - 0xfffff000   ( 736 kB)
   pkmap   : 0xff800000 - 0xffc00000   (4096 kB)
   vmalloc : 0xf7ffe000 - 0xff7fe000   ( 120 MB)
   lowmem  : 0xc0000000 - 0xf77fe000   ( 887 MB)
     .init : 0xc0106000 - 0xc0800000   (7144 kB)
     .data : 0xc0a18000 - 0xc0a5e0ec   ( 280 kB)
     .text : 0xc0800000 - 0xc09a5a55   (1686 kB)
Checking if this processor honours the WP bit even in supervisor mode...Ok.
SLUB: Genslabs=12, HWalign=64, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
Calibrating delay loop (skipped), value calculated using timer 
frequency.. 2400.86 BogoMIPS (lpj=3999780)
Security Framework initialized
Mount-cache hash table entries: 512
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 128K (64 bytes/line)
Checking 'hlt' instruction... OK.
SMP alternatives: switching to UP code
Freeing SMP alternatives: 17k freed
ACPI: Core revision 20080926
..TIMER: vector=0x30 apic1=0 pin1=2 apic2=-1 pin2=-1
CPU0: Centaur VIA Eden Processor 1200MHz stepping 00
Brought up 1 CPUs
Total of 1 processors activated (2400.86 BogoMIPS).
net_namespace: 728 bytes
Booting paravirtualized kernel on bare hardware
regulator: core version 0.5
NET: Registered protocol family 16
ACPI: bus type pci registered
bios32_service: base:000f0000 length:0000cbb4 entry:0000a3b0
PCI: PCI BIOS revision 2.10 entry at 0xa3b0, last bus=1    PCI: Using 
configuration type 1 for base access
ACPI Warning (dsobject-0501): Package List length (8) larger than 
NumElements count (2), truncated
[20080926]
ACPI Warning (dsobject-0501): Package List length (8) larger than 
NumElements count (2), truncated
[20080926]
ACPI: Interpreter enabled
ACPI: (supports S0 S1 S5)
ACPI: Using IOAPIC for interrupt routing
ACPI: No dock devices found.
ACPI: PCI Root Bridge [PCI0] (0000:00)
pci 0000:00:09.0: PME# supported from D1 D2 D3hot D3cold
pci 0000:00:09.0: PME# disabled
pci 0000:00:0a.0: PME# supported from D2 D3hot D3cold
pci 0000:00:0a.0: PME# disabled
pci 0000:00:0b.0: PME# supported from D1 D2 D3hot D3cold
pci 0000:00:0b.0: PME# disabled
pci 0000:00:0c.0: PME# supported from D1 D2 D3hot D3cold
pci 0000:00:0c.0: PME# disabled
pci 0000:00:10.0: PME# supported from D0 D1 D2 D3hot D3cold
pci 0000:00:10.0: PME# disabled
pci 0000:00:10.1: PME# supported from D0 D1 D2 D3hot D3cold
pci 0000:00:10.1: PME# disabled
pci 0000:00:10.2: PME# supported from D0 D1 D2 D3hot D3cold
pci 0000:00:10.2: PME# disabled
pci 0000:00:10.3: PME# supported from D0 D1 D2 D3hot D3cold
pci 0000:00:10.3: PME# disabled
pci 0000:00:10.4: PME# supported from D0 D1 D2 D3hot D3cold
pci 0000:00:10.4: PME# disabled
HPET not enabled in BIOS. You might try hpet=force boot option
pci 0000:00:12.0: PME# supported from D0 D1 D2 D3hot D3cold
pci 0000:00:12.0: PME# disabled
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 6 7 *10 11 12)
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 6 7 10 *11 12)
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 6 7 10 *11 12)
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 6 7 10 11 12) *5
ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 6 7 10 11 12) *0, disabled.
ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 6 7 10 11 12) *0, disabled.
ACPI: PCI Interrupt Link [LNK0] (IRQs 3 4 6 7 10 11 12) *0, disabled.
ACPI: PCI Interrupt Link [LNK1] (IRQs 3 4 6 7 10 11 12) *0, disabled.
ACPI: PCI Interrupt Link [ALKA] (IRQs *20)
ACPI: PCI Interrupt Link [ALKB] (IRQs *21)
ACPI: PCI Interrupt Link [ALKC] (IRQs *22)
ACPI: PCI Interrupt Link [ALKD] (IRQs *23)
PCI: Using ACPI for IRQ routing
NetLabel: Initializing
NetLabel:  domain hash size = 128
NetLabel:  protocols = UNLABELED CIPSOv4
NetLabel:  unlabeled traffic allowed by default
pnp: PnP ACPI init
ACPI: bus type pnp registered
pnp 00:09: IRQ 4 override to edge, high
pnp 00:0a: IRQ 3 override to edge, high
pnp: PnP ACPI: found 13 devices
ACPI: ACPI bus type pnp unregistered
PnPBIOS: Disabled by ACPI PNP
system 00:00: iomem range 0xf0000-0xfffff could not be reserved
system 00:00: iomem range 0xfe800000-0xfe8000ff has been reserved
system 00:00: iomem range 0xfea00000-0xfea000ff has been reserved
system 00:00: iomem range 0x3eee0000-0x3eefffff could not be reserved
system 00:00: iomem range 0xffff0000-0xffffffff has been reserved
system 00:00: iomem range 0x0-0x9ffff could not be reserved
system 00:00: iomem range 0x100000-0x3eedffff could not be reserved
system 00:00: iomem range 0xfec00000-0xfecfffff could not be reserved
system 00:00: iomem range 0xfee00000-0xfeefffff could not be reserved
system 00:00: iomem range 0xfff80000-0xfffeffff has been reserved
system 00:02: ioport range 0x400-0x47f has been reserved
system 00:02: ioport range 0x500-0x50f has been reserved
system 00:03: iomem range 0xfea00000-0xfea000ff has been reserved
system 00:04: ioport range 0x4d0-0x4d1 has been reserved
system 00:04: ioport range 0x800-0x805 has been reserved
system 00:04: ioport range 0x290-0x297 has been reserved
pci 0000:00:01.0: PCI bridge, secondary bus 0000:01
pci 0000:00:01.0:   IO window: 0xd000-0xdfff
pci 0000:00:01.0:   MEM window: 0xfb000000-0xfcffffff
pci 0000:00:01.0:   PREFETCH window: 0x000000f4000000-0x000000f7ffffff
bus: 00 index 0 io port: [0x00-0xffff]
bus: 00 index 1 mmio: [0x000000-0xffffffff]
bus: 01 index 0 io port: [0xd000-0xdfff]
bus: 01 index 1 mmio: [0xfb000000-0xfcffffff]
bus: 01 index 2 mmio: [0xf4000000-0xf7ffffff]
bus: 01 index 3 mmio: [0x0-0x0]
NET: Registered protocol family 2
IP route cache hash table entries: 32768 (order: 5, 131072 bytes)
TCP established hash table entries: 131072 (order: 8, 1048576 bytes)
TCP bind hash table entries: 65536 (order: 7, 524288 bytes)
TCP: Hash tables configured (established 131072 bind 65536)
TCP reno registered
NET: Registered protocol family 1
checking if image is initramfs...<7>Switched to high resolution mode on 
CPU 0
it is
Freeing initrd memory: 4355k freed
highmem bounce pool size: 64 pages
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
msgmni has been set to 1738
alg: No test for stdrng (krng)
Block layer SCSI generic (bsg) driver version 0.4 loaded (major 254)
io scheduler noop registered (default)
PCI: VIA PCI bridge detected.Disabling DAC.
pci 0000:00:11.0: Bypassing VIA 8237 APIC De-Assert Message
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Serial: 8250/16550 driver4 ports, IRQ sharing disabled
serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
serial8250: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
brd: module loaded
PNP: PS/2 Controller [PNP0303:PS2K] at 0x60,0x64 irq 1
PNP: PS/2 appears to have AUX port disabled, if this is incorrect please 
boot wi
th i8042.nopnp
serio: i8042 KBD port at 0x60,0x64 irq 1
Using IPI No-Shortcut mode
Freeing unused kernel memory: 7144k freed
Alpine Init 1.0
* Starting mdev: ok.
* Loading boot drivers: ok.
* Mounting boot media: ok.
* Mounting loopback device for kernel modules: ok.
* Loading hardware drivers: general protection fault: 0000 [#1] SMP
last sysfs file: /sys/devices/platform/pcspkr/input/input3/event3/dev
Modules linked in: serio_raw pcspkr shpchp pci_hotplug i2c_viapro 
i2c_core via_rhine snd_via82xx snd_ac97_codec ac97_bus snd_pcm snd_timer 
snd_page_alloc snd_mpu401_uart snd_rawmidi snd_seq_device snd soundcore 
gameport firewire_ohci firewire_core crc_itu_t via_agp agpgart r8169 mii 
bitrev crc32 evdev 8250_pnp parport_pc parport cramfs zlib_inflate loop 
nls_iso8859_1 nls_cp437 vfat fat nls_base sata_via ehci_hcd uhci_hcd 
via82cxxx ide_pci_generic ide_core pata_via pata_acpi ata_generic libata 
fan thermal button processor sd_mod usb_storage scsi_mod libusual usbcore

Pid: 1, comm: init Not tainted (2.6.28.7-grsec #1)
EIP: 0060:[<c090c078>] EFLAGS: 00010046 CPU: 0
EAX: 00000000 EBX: f702c000 ECX: f7065c00 EDX: 00000282
ESI: f7065800 EDI: f73ca000 EBP: 00000004 ESP: f702bf10
DS: 0068 ES: 0068 FS: 00d8 GS: 0000 SS: 0068
Process init (pid: 1, ti=f702a000 task=f702c000 task.ti=f702a000)
Stack:
f702c000 f7065c00 c08feba4 c08fd489 f73ca000 f70ab6c0 f7065ce4 f7065c00
00000000 f702c000 c081d358 f7065ce8 f7065ce8 00000004 f7065c00 00000004
00000000 c08fb9d7 00000004 00000004 5398b5fc f70ab6c0 c08fd3a4 f7065c14
Call Trace:
[<c08feba4>] 0xc08feba4
[<c08fd489>] 0xc08fd489
[<c081d358>] 0xc081d358
[<c08fb9d7>] 0xc08fb9d7
[<c08fd3a4>] 0xc08fd3a4
[<c08fba46>] 0xc08fba46
[<c0864a2b>] 0xc0864a2b
[<c0864b30>] 0xc0864b30
[<c08035d2>] 0xc08035d2
Code: 2b 58 50 8b 46 14 81 e3 ff 0f 00 00 e8 b4 44 09 00 89 d8 5b 5e c3 
56 53 8b b0 10 01 00 00 8b 46 14 e8 a5 43 09 00 89 c2 8b 46 10 <8b> 58 
4c f7 d3 03 58 50 8b 46 14 81 e3 ff 0f 00 00 e8 84 44 09
EIP: [<c090c078>]  SS:ESP 0068:f702bf10
---[ end trace 5e23806105684195 ]---

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Wed, 25 Mar 2009 08:00:46 +0100

> 1.8.x and earlier, but I'm not sure).

Thats probably true. The apkolv is now extracted from the initramfs so
when switching root busybox init have your /etc/inittab. Before you had
to modify the initramfs image. Now its enough to lbu commit.

> modules=usb-storage,sd-mod console=tty1,38400 console=ttyS0,9600

[snip]

> ---[ end trace 5e23806105684195 ]---

I believe there is a bug in a kernel driver. Exactly which one I don't
know. I guess we need to turn on some verbosity in modprobe to show
which modules are loaded or something o figure that out.

-nc

---