Subject: [alpine-devel] How best to track packages changes?

From: Mark Constable <[email-masked]>
Date: Tue, 04 Aug 2009 11:35:35 +1000

So this morning I did this and I'm wondering what is the best
way to see exactly what changes went into these updates?

# apk add -u alpine-sdk
Upgrading uclibc (0.9.30.1-r13 -> 0.9.30.1-r14)
Upgrading abuild (2.0_rc3-r1 -> 2.0_rc4-r0)
Upgrading uclibc-dev (0.9.30.1-r13 -> 0.9.30.1-r14)
Upgrading busybox (1.14.2-r2 -> 1.14.3-r0)
Executing busybox-1.14.3-r0.post-upgrade
OK: 134 packages, 471 dirs, 7051 files

--markc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Tue, 04 Aug 2009 07:56:38 +0200

> OK: 134 packages, 471 dirs, 7051 files

I suppose the git is the best way to see exactly what happened:
http://git.alpinelinux.org/cgit/aports/log/

btw. abuild-2.0_rc4 introduces -d to disable dependency tracing, as we
talked about ;)

-nc

---