Subject: [alpine-devel] noob question on package building documentation

From: Nathan Angelacos <[email-masked]>
Date: Sun, 20 Sep 2009 21:27:21 -0700

Following: http://wiki.alpinelinux.org/w/index.php?title=Creating_an_Alpine_package

I'm trying to build inter7's vpopmail (and, yes, I want to use it with postfix, so that will complicate things)

under the section "Depends& makedepends" there's discussion on how to figure out what to disable with abuild unpack

http://www.gentoo-portage.com/net-mail/vpopmail suggests:

                 --sysconfdir=${VPOP_HOME}/etc \
                 --enable-non-root-build \
                 --enable-qmaildir=${QMAIL_HOME} \
                 --enable-qmail-newu=${QMAIL_HOME}/bin/qmail-newu \
                 --enable-qmail-inject=${QMAIL_HOME}/bin/qmail-inject \
                 --enable-qmail-newmrh=${QMAIL_HOME}/bin/qmail-newmrh \
                 --enable-vpopuser=vpopmail \
                 --enable-vpopgroup=vpopmail \
                 --enable-many-domains \
                 --enable-file-locking \
                 --enable-file-sync \
                 --enable-md5-passwords \
                 --enable-logging \
                 --enable-auth-logging \
                 --enable-log-name=vpopmail \
                 --enable-qmail-ext \
                 --disable-tcp-rules-prog \
                 --disable-tcpserver-file \
                 --disable-roaming-users \

Fair enough.. but where do I put that in the abuild system?

Later on, in Configure options, it says  "we are not covering the  depend switched hser because we have discussed
this already in the depend section."

But there's no example of what the stuff from gentoo should look like in abuild.

It would probably be helpful to have a simple example.  Yes, looking at other abuilds helps, but it might
be helpful from the wiki viewpoint to offer a single, complete, example.

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Jeremy Thomerson <[email-masked]>
Date: Sun, 20 Sep 2009 23:43:37 -0500

I believe you just need to add those to your configure command.  See this
APKBUILD for an example....

http://git.alpinelinux.org/cgit/aports/tree/main/wireshark/APKBUILD

Jeremy

On Sun, Sep 20, 2009 at 11:27 PM, Nathan Angelacos <[email-masked]>wrote:

> Following:
> http://wiki.alpinelinux.org/w/index.php?title=Creating_an_Alpine_package
>
> under the section "Depends& makedepends" there's discussion on how to
> figure out what to disable with abuild unpack
>
> Unsubscribe:  [email-masked]<[email-masked]>
> Help:         [email-masked]<[email-masked]>
> ---
>
>
>