Subject: [alpine-devel] Alpine 2.1.4 does not boot on PC Engines Alix (AMD Geode) boxen

From: Nathan Angelacos <[email-masked]>
Date: Thu, 13 Jan 2011 23:31:53 -0800

Tried to upgrade 1.10.1 to 2.1.4 and it fails; attached are the dmesg 
from the working and non-working versions.

The only thing that strikes me is the

ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
Warning! ehci_hcd should always be loaded before uhci_hcd and ohci_hcd, 
not after

for 2.1.x (2.1.3, 2.1.2 failed as well)

I'll continue to look into why, but thought I'd post to the ml in case 
it had already been solved elsewhere.

---

From: Natanael Copa <[email-masked]>
Date: Fri, 14 Jan 2011 08:41:22 +0100

On Thu, 13 Jan 2011 23:31:53 -0800
Nathan Angelacos <[email-masked]> wrote:

> Warning! ehci_hcd should always be loaded before uhci_hcd and
> ohci_hcd, not after
> 
> I'll continue to look into why, but thought I'd post to the ml in
> case it had already been solved elsewhere.

Where does it stop? Do you get emergency shell? Does it hang? Do you
get any error message?

From the dmesgs I can only guess that you get an emergency shell since
it goes all the way til it finds the CF card (sda1) and there it stops.
The "works" dmesg doesnt show any sda1? What do you have as alpine_dev
in your syslinux.cfg?

If you get an emergency shell, can you manually mount the alpine_dev?

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Nathan Angelacos <[email-masked]>
Date: Fri, 14 Jan 2011 07:59:09 -0800

> Where does it stop? Do you get emergency shell? Does it hang? Do you
It stops after detecting sda1

scsi 0:0:0:0: Direct-Access     ATA      CF CARD 1GB      2007 PQ: 0 ANSI: 5
sd 0:0:0:0: [sda] 1981728 512-byte logical blocks: (1.01 GB/967 MiB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn't 
support DPO or FUA
  sda: sda1
sd 0:0:0:0: [sda] Attached SCSI disk

no Alpine rc_init, no shell.

---

---

From: Nathan Angelacos <[email-masked]>
Date: Fri, 14 Jan 2011 10:45:09 -0800

> no Alpine rc_init, no shell.

Acutally, it could have the emergency shell, but since Alix boards are 
headless, if the emergency shell doesn't honor the console=ttyS0,9600 
kernel statement, there would be no way to tell.

---

---

From: Nathan Angelacos <[email-masked]>
Date: Fri, 14 Jan 2011 10:50:40 -0800

Continuing my conversation with myself....

> kernel statement, there would be no way to tell.

Which lead to the solution to that problem.   I had "console=ttyS0,9600 
console=tty1,38400" on the kernel command line

Its headless, so there is no tty1.

Now Alpine boots, and hangs detecting hardware:

sd 0:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn't 
support DPO or FUA
  sda: sda1
sd 0:0:0:0: [sda] Attached SCSI disk
ok.
  * Mounting boot media: ok.
  * Installing packages to root filesystem: -[####################]- 100%ok.

    OpenRC 0.6.1.562d570 is starting up Linux 2.6.35.10-grsec (i586)

* /proc is already mounted, skipping
* Caching service dependencies... [ok]
* Caching service dependencies... [ok]
* Clock skew detected with `/etc/init.d/modules'
* Adjusting mtime of `/libexec/rc/init.d/deptree' to Fri Jan  7 13:36:18 
2011

* Mounting security filesystem... [ok]

* Mounting debug filesystem... [ok]
* Starting busybox mdev... [ok]
* Mounting loopback device for kernel modules... [ok]
* Loading hardware drivers...

---

---

From: Nathan Angelacos <[email-masked]>
Date: Fri, 14 Jan 2011 13:11:20 -0800

The offending driver that causes the hang is "cs5535-mfgpt"

#modprobe cs5535-mfgpt"
pci 0000:00:0f.0: allocated PCI BAR #2: base 0x6200
<silence>

According to
http://140.211.166.79/mailarchive/linux-kernel/2010/10/23/4636377

It looks like the kernel now has a new config option (as of Oct 2010); 
but I can't find it listed in

http://git.alpinelinux.org/cgit/aports/tree/main/linux-grsec/kernelconfig.x86

---
btw, blacklisting cs5535-mfgpt allows the box to boot, but then the ac97 
sound driver (and anything else that depends on the geode mfd driver) fails.

---

---

From: Natanael Copa <[email-masked]>
Date: Sat, 22 Jan 2011 19:16:46 +0000

> The offending driver that causes the hang is "cs5535-mfgpt"

 Good work!

> It looks like the kernel now has a new config option (as of Oct
> 2010); but I can't find it listed in
>
> 

 Good! Care to file a bug for this so it does not gets forgotten? I'll 
 have a look at it when I get a chance. (I am on vacation in brazil now)

 -nc

---