Subject: [alpine-devel] Installation woes

From: Nat! <[email-masked]>
Date: Thu, 10 Feb 2011 21:02:02 +0100

Hi

from the website I got the impression, it's OK to ask for help here.
I have quite a few questions :)

My major problem is, that I want to install Alpine on an Atom box, that has no PS/2 connector. I can only connect an USB keyboard. This doesn't work (for me). The Atom uses an Intel 945 GSE chipset (it's this -> http://www.lex.com.tw/product/3I270D_b.htm) On the same box I have no problems with a fresh Debian 6.0 (sid).  

I am trying to install Alpine to a CF Flash that I use with a card reader. I usually use VMware, but I see no difference with a CDROM + laptop -> USB CF setup. I have no problem setting up the CF flash, except that I can't get syslinux to boot. I tried a variety of the supplied mbr.bin bootloaders (copied to /dev/sdb not /dev/sdb1 to be sure), but it never worked out (It's a 128 MB flash. The partition is primary 1, bootable).

I then used Debian to put a grub on it. With the addition of the modloop=boot/grsec.cmg flag this succeeds in booting Alpine and there are no apparent error messages. I also managed to get eth0 up and working, by inclusion of r8169 as a kernel parameter. 

Now here is where it gets stupid. I could live without the keyboard, if I could ssh up into it. I configured the apk cache and installed openssh. Configured the init.d with rc-update, and started sshd with /etc/init.d/sshd start. Everything looks fine. I configured lbu to save stuff to the card, and do 
lbu ci. The apkovl file appears on the card. 

But when I reboot, /etc/init.d/sshd is gone again (though /etc/ssh exists). I surmise, that this is because the openssh apk isn't properly loaded. I assume it isn't loaded, since it only appears in /etc/apk/cache/tmp. I didn't put it there. Another theory I have is that loading is ahead of mounting.

I have to admit, I am clueless as to when and where Alpine Init loads the apk stuff, I didn't see anything in /etc/conf.f or /etc/init.d. It would be interesting to know how to debug/trace that.

Mainly though, how do I get a USB keyboard working ?

Ciao
    Nat!
---------------------------------------------------
I couldn't work without a deadline. If I retired to 
some luxurious home by the sea, you know what I 
would write? Nuthin' !  -- Duke Ellington

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Jeff Bilyk <[email-masked]>
Date: Thu, 10 Feb 2011 17:31:51 -0500

Hi Nat,

I recently noticed a few devices that didn't work out of the box
(mostly laptop touchpads for me, but also a few keyboards).  The
solution for me has been to install udev (apk add udev), start it and
set it to auto-start (rc-update add udev && rc-update add
udev-postmount && /etc/init.d/udev start && /etc/init.d/udev-postmount
start).  IIRC, some of the main developers were thinking about
enabling by default (correct me here if I'm wrong ncopa/nenolod).

As for the ssh disappearing, more than likely it's because apk wasn't
able to find a local copy of the apk .  After you've enabled apk
caching, run the 'apk cache sync' command, which will download a local
copy of any installed apks to the apk cache directory.

Jeff

-- 
Jeff

---

---

From: Nat! <[email-masked]>
Date: Fri, 11 Feb 2011 12:09:11 +0100

> copy of any installed apks to the apk cache directory.
I did that, and the files are indeed then moved out of cache/tmp and placed into cache directly. 
And then rebooting with sshd works!

So if apk cache sync is now required, and this isn't a bug, it would be helpful to add this to 
http://www.alpinelinux.org/wiki/Setting_up_a_ssh-server and possibly some other places.
 
Thanks for the help
   Nat!

---

---

From: Timo Teräs <[email-masked]>
Date: Fri, 11 Feb 2011 14:05:27 +0200

> And then rebooting with sshd works!

Yes, this is a bug. It's been fixed quite a bit ago, and is on the way
to next release.

- Timo

---

---

From: Carlo Landmeter <[email-masked]>
Date: Fri, 11 Feb 2011 10:04:40 +0100

> My major problem is, that I want to install Alpine on an Atom box, that has no PS/2 connector. I can only connect an USB keyboard. This doesn't work (for me). The Atom uses an Intel 945 GSE chipset…

Can you try to load usbkbd module? see if that helps.

> I am trying to install Alpine to a CF Flash that I use with a card reader. I usually use VMware, but I see no difference with a CDROM + laptop -> USB CF setup. I have no problem setting up the CF f…

Are you using FAT or EXT partition? you will need extlinux for EXT and
make sure the parittion is bootable (i forget that many times)

> I have to admit, I am clueless as to when and where Alpine Init loads the apk stuff, I didn't see anything in /etc/conf.f or /etc/init.d. It would be interesting to know how to debug/trace that.

Alpine will look for a directory containing apk's which has a hidden file:

.boot_repository

Can you check if this file is included in your local apk folder?

---

---

From: Nat! <[email-masked]>
Date: Fri, 11 Feb 2011 12:26:28 +0100

> Can you try to load usbkbd module? see if that helps.

This indeed helps. Yay!
> make sure the parittion is bootable (i forget that many times)

With hindsight, as it is now working, I might have made the partition bootable after configuring syslinux. The partition itself was marked as bootable and I didn't change this on my last (successful attempt). 
  
> Can you check if this file is included in your local apk folder?

Yes it is included in /media/usb/apks but not in /media/usb/cache, where the openssh apks reside.
But it's now working (see last mail). Is there a way to trace what is happening ? When exactly      
are the apks loaded during booting ?

Thanks for the help. Alpine is apparently running fine now on the machine.

Nat! 

---