Subject: [alpine-devel] Shorewall patch that resolves the shorewall ipset+iptables issue

From: Harry Lachanas <[email-masked]>
Date: Tue, 04 Oct 2011 09:36:58 +0300

Alpine 2.2.3
shorewall v4.2.10
iptables v1.4.10
ipset v4.5

iptables complaints about the "-m set --set" and  recommends to use "-m 
set --match-set" syntax.

/usr/share/shorewall/lib.cli,
/usr/share/shorewall/lib.config
and
/usr/share/shorewall-shell/compiler

need to be patched
The patch files are included

Please note that

previous versions of ipset
included the -U option ( unbind )
In the new version I was not able to locate the equivalent options since 
the "-U" option is not supported anymore.

Regards
Harry
( Please excuse the quality of the patch files since I am not  familiar 
or using diff etc in in my code )

--- lib.cli
+++ lib.cli
@@ -315,8 +315,6 @@
 					grep 'loadmodule ip_set' ${VARDIR}/.modules >> $f
 					echo "__EOF__" >> $f
 					echo  >> $f
-					echo "ipset -U :all: :all:" >> $f
-					echo "ipset -U :all: :default:" >> $f
 					echo "ipset -F" >> $f
 					echo "ipset -X" >> $f
 					echo "ipset -R << __EOF__" >> $f
--- lib.config
+++ lib.config
@@ -884,7 +884,7 @@
 	    ;;
     esac
 
-    echo "--set ${setname#+} $options"
+    echo "--match-set ${setname#+} $options"
 }
 
 #

--- compiler
+++ compiler
@@ -5627,8 +5627,6 @@
 
 if [ -f \$f ]; then
     progress_message2 "Restoring IPSETS..."
-    ipset -U :all: :all:
-    ipset -U :all: :default:
     ipset -F
     ipset -X
     ipset -R < \$f

---

From: Natanael Copa <[email-masked]>
Date: Wed, 5 Oct 2011 13:34:12 +0200

On Tue, 04 Oct 2011 09:36:58 +0300
Harry Lachanas <[email-masked]> wrote:

> Alpine 2.2.3
> shorewall v4.2.10
> iptables v1.4.10
> ipset v4.5
> 
> iptables complaints about the "-m set --set" and  recommends to use
> "-m set --match-set" syntax.
> 

I don't find those files in shorewall?

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Harry Lachanas <[email-masked]>
Date: Wed, 05 Oct 2011 20:11:34 +0300

On 10/05/2011 02:34 PM, Natanael Copa wrote:
> Harry Lachanas<[email-masked]>  wrote:
>
>> Alpine 2.2.3
>> shorewall v4.2.10
>> iptables v1.4.10
>> ipset v4.5
>>
They are included in the shorewall-common-4.2.10-r1.apk

and the compiler file in the

shorewall-shell-4.2.10-r2.apk

Harry

---