Subject: [alpine-devel] [Patch] dhcpd will crash on start-up, if pid file folder does not exist

From: Der Tiger <[email-masked]>
Date: Sun, 25 Mar 2012 17:00:58 +0200

Hi,

This is to prevent dhcpd to crash during boot, when the pid file is to
be created in a missing folder, eg. on a volatile disk space like a
tmpfs after boot.

Please, consider updating the dhcpd init file.

Kind Regards, Tiger

--- /etc/init.d/dhcpd.orig
+++ /etc/init.d/dhcpd
@@ -73,0 +74,3 @@
+    mkdir -p "$(echo $pidfile | sed 's|/[^/]*$||')"
+    chown dhcp "$(echo $pidfile | sed 's|/[^/]*$||')"
+    chgrp dhcp "$(echo $pidfile | sed 's|/[^/]*$||')"

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Mon, 26 Mar 2012 20:49:07 +0200

On Sun, 25 Mar 2012 17:00:58 +0200

> Please, consider updating the dhcpd init file.

Hi, Thanks for feedback. Please see comments on mini_httpd. We should
use checkpath for this.

---