Subject: [alpine-devel] [PATCH] main/nginx: upgrade to 1.0.14

From: Bartłomiej Piotrowski <[email-masked]>
Date: Sat, 31 Mar 2012 08:47:24 +0200

I've removed unused variables and added pcre, openssl and zlib to deps.
In the most of distros they're needed to start nginx, but I can be wrong
of course.

-- 
Bartłomiej Piotrowski
http://bpiotrowski.pl/
>From 071d0baaf145c654c24cc53fc1476500c3997eaf Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Bart=C5=82omiej=20Piotrowski?= <[email-masked]>
Date: Sat, 31 Mar 2012 08:36:47 +0200
Subject: [PATCH] main/nginx: upgrade to 1.0.14

---
 main/nginx/APKBUILD |   24 ++++++++++--------------
 1 file changed, 10 insertions(+), 14 deletions(-)

diff --git a/main/nginx/APKBUILD b/main/nginx/APKBUILD
index 1cdb287..9fa5e41 100644
--- a/main/nginx/APKBUILD
+++ b/main/nginx/APKBUILD
@@ -1,29 +1,25 @@
+# Maintainer:  Cameron Banta <[email-masked]>
 # Contributor: Jeff Bilyk <[email-masked]>
-# Maintainer: Cameron Banta <[email-masked]>
+# Contributor: Bart��omiej Piotrowski <[email-masked]>
+
 pkgname=nginx
-pkgver=1.0.11
+pkgver=1.0.14
 pkgrel=1
-pkgdesc="nginx [engine x] is a HTTP and reverse proxy server"
+pkgdesc="lightweight HTTP and reverse proxy server"
 url="http://www.nginx.org"
 arch="all"
 license="Custom"
-depends=
+depends="openssl pcre zlib"
 makedepends="pcre-dev openssl-dev zlib-dev"
-#install="$pkgname.pre-install $pkgname.post-install"
-install=
-subpackages=
 source="http://nginx.org/download/$pkgname-$pkgver.tar.gz
-	nginx.initd
-	nginx.logrotate
-	$install
-	ipv6.patch
-	"
+	    nginx.initd
+	    nginx.logrotate
+	    ipv6.patch"
 
 _builddir="$srcdir"/$pkgname-$pkgver
 
 prepare() {
 	cd "$_builddir"
-	# apply patches here
 	patch -Np1 -i "$srcdir"/ipv6.patch
 }
 
@@ -57,7 +53,7 @@ package() {
 	install -m644 -D LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
 }
 
-md5sums="a41a01d7cd46e13ea926d7c9ca283a95  nginx-1.0.11.tar.gz
+md5sums="019844e48c34952253ca26dd6e28c35c  nginx-1.0.14.tar.gz
 4faf8dff6ff1490edae1688baf1b2abb  nginx.initd
 8823274a834332d3db4f62bf7dd1fb7d  nginx.logrotate
 801a87f7f9d27f8ad85b41a78b4c4461  ipv6.patch"
-- 
1.7.9.5

---

From: Natanael Copa <[email-masked]>
Date: Sat, 31 Mar 2012 15:59:43 +0200

On Sat, 31 Mar 2012 08:47:24 +0200
Bartłomiej Piotrowski <[email-masked]> wrote:

> I've removed unused variables and added pcre, openssl and zlib to
> deps. In the most of distros they're needed to start nginx, but I can
> be wrong of course.

Those should be pulled in automatically.

$ apk info -R nginx
nginx-1.0.11-r1 depends on:
libgcc
libc0.9.32
libcrypto1.0
pcre
libssl1.0
zlib

Cameron, since you are maintainer, do you think you could clean this up
and send me a patch that I can git am?

Thanks!

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Cameron Banta <[email-masked]>
Date: Sat, 31 Mar 2012 21:19:24 -0500

Done.