Subject: [alpine-devel] [PATCH] main/gawk: upgrade to 4.0.1

From: Bartłomiej Piotrowski <[email-masked]>
Date: Tue, 03 Apr 2012 16:54:40 +0200

---
 main/gawk/APKBUILD |   14 ++++++--------
 1 file changed, 7 insertions(+), 9 deletions(-)

diff --git a/main/gawk/APKBUILD b/main/gawk/APKBUILD
index e86dafb..90f9943 100644
--- a/main/gawk/APKBUILD
+++ b/main/gawk/APKBUILD
@@ -1,18 +1,16 @@
-# Contributor: Michael Mason <[email-masked]>
 # Maintainer: Natanael Copa <[email-masked]>
+# Contributor: Michael Mason <[email-masked]>
+# Contributor: Bartłomiej Piotrowski <[email-masked]>
+
 pkgname=gawk
-pkgver=4.0.0
+pkgver=4.0.1
-pkgrel=1
+pkgrel=0
 pkgdesc="GNU awk pattern-matching language"
 url="http://www.gnu.org/software/gawk/gawk.html"
 arch="all"
 license="GPL"
-depends=
-makedepends=""
-install=
 subpackages="$pkgname-doc"
-source="http://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz
-       $install"
+source="http://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz"

 build() {
        cd "$srcdir/$pkgname-$pkgver"
@@ -33,4 +31,4 @@ package() {

 }

-md5sums="51e417b71287629940051e6f652c6492  gawk-4.0.0.tar.gz"
+md5sums="a601b032c39cd982f34272664f8afa49  gawk-4.0.1.tar.xz"
-- 
1.7.9.5

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Tue, 3 Apr 2012 22:51:56 +0200

On Tue, 03 Apr 2012 16:54:40 +0200

>  1 file changed, 7 insertions(+), 9 deletions(-)

Applying: main/gawk: upgrade to 4.0.1
error: patch failed: main/gawk/APKBUILD:1
error: main/gawk/APKBUILD: patch does not apply
Patch failed at 0001 main/gawk: upgrade to 4.0.1

Did you use git send-email?

-nc

---

---

From: Bartłomiej Piotrowski <[email-masked]>
Date: Wed, 04 Apr 2012 06:37:45 +0200

> Did you use git send-email?

No, I'm creating patches with format-patch and then use Thunderbird.
Anyway, the patch in the attachment should works - I've checked it this
time.

-- 
Bartłomiej Piotrowski
http://bpiotrowski.pl/
>From 8d031c07c1ab2607f3b5246cd1f3baa8fe3bc2c6 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Bart=C5=82omiej=20Piotrowski?= <[email-masked]>
Date: Wed, 4 Apr 2012 06:14:28 +0200
Subject: [PATCH] main/gawk: upgrade to 4.0.1

---
 main/gawk/APKBUILD |   15 ++++++---------
 1 file changed, 6 insertions(+), 9 deletions(-)

index e86dafb..a17cb74 100644
@@ -1,18 +1,15 @@
+# Contributor: Bart��omiej Piotrowski <[email-masked]>
 
 build() {
 	cd "$srcdir/$pkgname-$pkgver"
@@ -33,4 +30,4 @@ package() {
 
 }