Subject: [alpine-devel] [PATCH] main/mutt: upgrade to 1.5.21

From: Bartłomiej Piotrowski <[email-masked]>
Date: Tue, 03 Apr 2012 16:55:09 +0200

---
 main/mutt/APKBUILD |   41 +++++++++++++++++++----------------------
 1 file changed, 19 insertions(+), 22 deletions(-)

diff --git a/main/mutt/APKBUILD b/main/mutt/APKBUILD
index 69ab253..8a0a268 100644
--- a/main/mutt/APKBUILD
+++ b/main/mutt/APKBUILD
@@ -1,39 +1,36 @@
-# Contributor: Andrew Manison<[email-masked]>
-# Maintainer:  Andrew Manison<[email-masked]>
+# Maintainer:  Andrew Manison <[email-masked]>
+# Contributor: Bartłomiej Piotrowski <[email-masked]>
 pkgname=mutt
-pkgver=1.4.2.3
-pkgrel=5
-pkgdesc="a small but very powerful text-mode email client"
+pkgver=1.5.21
+pkgrel=0
+pkgdesc="Small but very powerful text-mode email client"
 url="http://www.mutt.org"
 arch="all"
 license="GPL"
-depends=
-makedepends="openssl-dev ncurses-dev libiconv-dev gettext-dev"
-install=
+makedepends="cyrus-sasl-dev db-dev gettext-dev gpgme-dev libiconv-dev
libidn-dev ncurses-dev openssl-dev perl"
 subpackages="$pkgname-doc $pkgname-lang"
-source="ftp://ftp.mutt.org/$pkgname/$pkgname-$pkgver.tar.gz"
+source="ftp://ftp.gnupg.org/$pkgname/devel/$pkgname-$pkgver.tar.gz"

 _builddir="$srcdir"/$pkgname-$pkgver

-prepare() {
-	cd "$_builddir"
-	# apply patches here
-}
-
 build() {
 	cd "$_builddir"
-	./configure --prefix=/usr \
+
+	./configure \
+	    --prefix=/usr \
 		--sysconfdir=/etc \
-		--mandir=/usr/share/man \
-		--infodir=/usr/share/info \
+		--enable-gpgme \
+		--enable-hcache \
 		--enable-imap \
 		--enable-pop \
 		--enable-smtp \
-		--with-curses \
+		--with-curses=/usr \
+		--with-idn \
 		--with-mailpath=/var/spool/mail \
-		--with-docdir=/usr/share/doc/mutt \
-		--without-included-gettext \
-		--with-ssl
+		--with-regex \
+		--with-ssl \
+		--with-sasl
+
 	make || return 1
 }

@@ -42,4 +39,4 @@ package() {
 	make DESTDIR="$pkgdir" install
 }

-md5sums="dcb94661827dd090fa813e73e122ea0c  mutt-1.4.2.3.tar.gz"
+md5sums="a29db8f1d51e2f10c070bf88e8a553fd  mutt-1.5.21.tar.gz"
-- 
1.7.9.5

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Bartłomiej Piotrowski <[email-masked]>
Date: Tue, 03 Apr 2012 16:57:54 +0200

I'm not sure if package shouldn't hit testing first. It's quite big
upgrade with new features.

-- 
Bartłomiej Piotrowski
http://bpiotrowski.pl/

---

---

From: Bartłomiej Piotrowski <[email-masked]>
Date: Sat, 14 Apr 2012 10:55:34 +0200

Bump.

-- 
Bartłomiej Piotrowski
http://bpiotrowski.pl/

---

---

From: Natanael Copa <[email-masked]>
Date: Wed, 18 Apr 2012 20:08:57 +0200

On Sat, 14 Apr 2012 10:55:34 +0200

> Bump.

I pushed a slightly differnet version that actually enables gpgme, adds
gpg and colors to default config + a /etc/Muttrc.local (like fedora
does). I think it might also have a working spellchecker if hunspell is
installed.

Please test how it works.

-nc

---