Subject: [alpine-devel] New acf-heimdal package

From: Ted Trask <[email-masked]>
Date: Tue, 25 Aug 2009 11:21:03 -0700 (PDT)

Here's a patch to add acf-heimdal.

Ted Trask

From 5907523452d594ec0dd8a517d186c9e0f5d33acb Mon Sep 17 00:00:00 2001
From: Ted Trask <[email-masked]>
Date: Tue, 25 Aug 2009 18:18:19 +0000
Subject: [PATCH] mail/acf-heimdal: New ACF package for heimdal

---
 main/acf-heimdal/APKBUILD |   21 +++++++++++++++++++++
 1 files changed, 21 insertions(+), 0 deletions(-)
 create mode 100644 main/acf-heimdal/APKBUILD

diff --git a/main/acf-heimdal/APKBUILD b/main/acf-heimdal/APKBUILD
new file mode 100644
index 0000000..523e2ab
--- /dev/null
+++ b/main/acf-heimdal/APKBUILD
@@ -0,0 +1,21 @@
+# Contributor: Ted Trask <[email-masked]>
+pkgname=acf-heimdal
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="ACF module for heimdal"
+url="http://git.alpinelinux.org/cgit/$pkgname"
+license="GPL-2"
+depends="acf-core lua heimdal"
+makedepends=""
+install=
+subpackages=""
+source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2"
+
+build() {
+        cd "$srcdir/$pkgname-$pkgver"
+
+        make DESTDIR="$pkgdir" install
+
+}
+
+md5sums="42c9fe3b719671ac037726e03d9eb926  acf-heimdal-0.1.0.tar.bz2"
-- 
1.6.3.3

---

From: Michael Mason <[email-masked]>
Date: Tue, 25 Aug 2009 19:39:19 +0000

> Here's a patch to add acf-heimdal.
Applied patch and pushed to my git repository.
Tried to build the package to verify but ran into some errors with the  
apks it depends on...

alp-dev:~/aports/main/acf-heimdal# abuild -r
 >>> acf-heimdal: Checking sanity of ./APKBUILD...
 >>> WARNING: acf-heimdal: No maintainer
 >>> acf-heimdal: Analyzing dependencies...
WARNING: Failed to open index for /root/.cache/apks
Installing haserl (0.9.25-r1)
ERROR: Failed to set file permissions on usr/bin/haserl.apk-new:  
Permission denied
ERROR: haserl-0.9.25-r1: Permission denied
 >>> ERROR: acf-heimdal: all failed
OK: 34 packages, 216 dirs, 5904 files

Nothing seems to be wrong with the patch except no Maintainer, but we  
might have to look at some of the apks on the mirrors?

I get similar errors when trying to upgrade to the new version of sudo.

alp-dev:~/aports/main/acf-heimdal# apk add -u sudo
Upgrading sudo (1.7.2-r0 -> 1.7.2_p1-r0)
ERROR: Failed to set file permissions on usr/bin/sudoedit.apk-new:  
Permission denied
ERROR: sudo-1.7.2_p1-r0: Permission denied

>
> <0001-mail-acf-heimdal-New-ACF-package-for-heimdal.patch>

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Mon, 31 Aug 2009 09:42:53 +0200

Hi,

back from vacation

> WARNING: Failed to open index for /root/.cache/apks

I'd recommend that you use a non-root user to do the building. The user
needs sudo access though to install dependencies.

> ERROR: haserl-0.9.25-r1: Permission denied

haserl have suid bit set...

> I get similar errors when trying to upgrade to the new version of sudo.

...and so has sudo.
> ERROR: sudo-1.7.2_p1-r0: Permission denied

can you check so you dont have a partition mounted with nosuid or
similar?

-nc

---