Subject: [alpine-devel] problem with UTF-8 on console

From: Jens Vehlhaber <[email-masked]>
Date: Thu, 02 May 2013 12:08:41 +0200

Hello developers

I have a problem with the UTF-8 support on the console. A simple test to
show you the problem: Install kbd package and with commands

# kbd_mode -u -C /dev/tty1; kbd_mode -u -C /dev/tty2 ...

set keyboard mode to Unicode. Now create a file with a German character
on its name. This produces the following result:

# touch Müller.txt
# ls
M??ller.txt

Another simple test with midnight commander:

# mcedit /lib/kbd/consoletrans/utflist
- Press F7 for search function
- Type the German character 'ä'
- The input field show '??'!
- After pressing enter key, mcedit finds the correct entry

   '00e4   ä   LATIN SMALL LETTER A WITH DIAERESIS'

(tested with version alpinelinux 2.4.10 and 2.5.4)

I miss the locale files for correct usage of UTF-8 characters on the
limited console character set.

Kind regards,
Jens

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Thu, 2 May 2013 13:43:25 +0200

On Thu, 02 May 2013 12:08:41 +0200

> Hello developers

Hi,
 
> limited console character set.

Localization is a weak spot in Alpine Linux (and uclibc in general). I think that support for UTF-8 would be nice, so it would be nice if somebody find out what is needed to make it work.

Do you think you could file a bug for this in bugs.a.o so we don't forget it?

Thanks!

-nc

---