Subject: [alpine-devel] Quagga setup bug

From: HL <[email-masked]>
Date: Fri, 30 Aug 2013 11:35:35 +0300

Hello,

It seems that when installing quagga the /etc/quagga dir
is owned by root.root but it should be quagga.root

Thank's
Harry

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Fri, 30 Aug 2013 11:27:19 +0200

On Fri, 30 Aug 2013 11:35:35 +0300

> is owned by root.root but it should be quagga.root

Are you sure? quagga should not edit the config files itself, should it?

-nc

---

---

From: HL <[email-masked]>
Date: Fri, 30 Aug 2013 12:48:00 +0300

> Are you sure? quagga should not edit the config files itself, should it?
Yes ...
for instance ...

Quagga programs have an interface similar to cisco

telnet localhost zebra ...
enable
conf terminal
bla bla bla
write

and the zebra process should be able to write the conf etc ...

---

---

From: Natanael Copa <[email-masked]>
Date: Fri, 30 Aug 2013 15:24:25 +0200

On Fri, 30 Aug 2013 12:48:00 +0300

> and the zebra process should be able to write the conf etc ...

I checked what fedora does:
http://pkgs.fedoraproject.org/cgit/quagga.git/tree/quagga.spec#n131

Basically, they make zebra.conf and vtysh.conf owned by quagga from
post-install script. They don't let quagga:quagga create new files or
delete existing by setting the permission on /etc/quagga. Instead,
quagga user can only edit existing files.

basically, it is up to the creator of the files and quagga package does
not create them. Maybe it should?

-nc

---

---

From: Timo Teras <[email-masked]>
Date: Fri, 30 Aug 2013 16:49:33 +0300

On Fri, 30 Aug 2013 15:24:25 +0200
Natanael Copa <[email-masked]> wrote:

> basically, it is up to the creator of the files and quagga package
> does not create them. Maybe it should?

I thought quagga writes first a temp file to same dir, and then renames
it as the original filename. I needed to make the dir writable to
quagga because of this in many installs.

- Timo

---

---

From: Natanael Copa <[email-masked]>
Date: Fri, 30 Aug 2013 16:24:56 +0200

On Fri, 30 Aug 2013 16:49:33 +0300

> quagga because of this in many installs.

ok, lets chown quagga /etc/quagga then to keep things simple.

-nc

---