Subject: [alpine-devel] abuild: add a short notification after check_arch in all()

From: "Leslie P. Polzer | PORT ZERO" <[email-masked]>
Date: Sun, 10 Nov 2013 15:59:36 +0100

This patch makes abuild print a message in all() mode
if the package will not be built due to it being not
available for the requested architecture.

This is important especially for users new to Alpine.

  Leslie

-- 
Dipl.Ing.(BA) Leslie P. Polzer | CTO - PORT ZERO
UG (haftungsbeschränkt)
Softwareentwicklung & IT Engineering
Adalbertstraße 7/8
10999 Berlin
Tel.: +49 (0)30 - 69 200 907 - 0
Fax: +49 (0)30 - 69 200 907 - 9
http://www.port-zero.com
>From fe42824c9cdd6d6aab74cb67be01c94bbb1e3d54 Mon Sep 17 00:00:00 2001
From: "Leslie P. Polzer" <[email-masked]>
Date: Sun, 10 Nov 2013 15:56:40 +0100
Subject: [PATCH] all(): print a message if aborting due to architecture
 mismatch.

---
 abuild.in | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

diff --git a/abuild.in b/abuild.in
index cfd531a..c020a13 100755
--- a/abuild.in
+++ b/abuild.in
@@ -1759,7 +1759,11 @@ uninstalldeps() { undeps; }
 
 all() {
 	if ! [ -n "$force" ]; then
-		check_arch || return 0
+		check_arch
+		if [ $? -ne 0 ]; then
+			echo "Package not available for the target architecture ($CARCH). Aborting."
+			return 0
+		fi
 		check_libc || return 0
 	fi
 	if up2date && [ -z "$force" ]; then
-- 
1.8.4.1

---

From: Natanael Copa <[email-masked]>
Date: Fri, 15 Nov 2013 17:04:39 +0100

On Sun, 10 Nov 2013 15:59:36 +0100

> This is important especially for users new to Alpine.

applied with slightly different commit message.
Thanks!

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---