Subject: [alpine-devel] inconsistent reboot ...

From: HL <[email-masked]>
Date: Mon, 11 Nov 2013 21:40:17 +0200

Hello there,
I had to do a live reboot on a fw running 2.6.0

I've compiled  locally
shorewall 4.5.20
and quagga with some patches not included in the dist.

I have a local cache
cache -> /media/usb/cache
in /etc/apk

my
/etc/apk/world  looks like this
shorewall-core><Q1QMfKKDCKoH9UNLUEMojyi4Q37BQ=
swatch
shorewall><Q1yYOHUXTd/LSuPXssSS3t1PNVnO0=
bird6><Q1BiVS1wDhjqZMmt5au2F9xxbgswU=
ipset
xtables-addons
ulogd
quagga><Q1TakQA3lBWumDxIrjN2kgQzlejs0=
shorewall6><Q152Aqg0C8W38vH+qw0VaH8W/zeoc=

at reboot the system complaints that could not find shorewall and the 
other locally compiled packages
so I had to re-install them manually.

and firewall did not start ...
In other words it cannot install the files of the locally compiled packages
and it is stubborn to expect the alpine distributed shorewall

question is
what went wrong ??

Is my world file OK or a mess??
Can it be fixed??

is it a signature issue ???
are signatures loaded before packages ???

Thanks for your answers
Harry.

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Tue, 12 Nov 2013 09:55:59 +0100

On Mon, 11 Nov 2013 21:40:17 +0200

> and it is stubborn to expect the alpine distributed shorewall

I believe apk needs to find the packages at boot, they need to be in a
repository listed in /etc/apk/repositories in other words.

> Is my world file OK or a mess??

Create a repository for your locally built packages. For example:

 copy them to /media/usb/myrepo/x86/
 
   cd /media/usb/myrepo/x86 && apk index -o APKINDEX.tar.gz *.apk
   abuild-sign APKINDEX.tar.gz

Make sure that the .pub key is in /etc/apk/keys.

> are signatures loaded before packages ???

The signatures are embedded in the .apk.

-nc

---