Subject: [alpine-devel] alpine-iso: USBIMG vs isohybrid

From: "Leslie P. Polzer | PORT ZERO" <[email-masked]>
Date: Mon, 18 Nov 2013 17:31:36 +0100

Hi,

is there a specific reason for the USBIMG section in the
Makefile? A simpler alternative would be running isohybrid
on the built ISO image.

  Leslie

-- 
Dipl.Ing.(BA) Leslie P. Polzer | CTO - PORT ZERO
UG (haftungsbeschränkt)
Softwareentwicklung & IT Engineering
Adalbertstraße 7/8
10999 Berlin
Tel.: +49 (0)30 - 69 200 907 - 0
Fax: +49 (0)30 - 69 200 907 - 9
http://www.port-zero.com

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Tue, 19 Nov 2013 13:27:36 +0100

On Mon, 18 Nov 2013 17:31:36 +0100

> Makefile? A simpler alternative would be running isohybrid

Yes. The problem is that vfat does not support resize. We store apkvols
and often the apk cache on the USB stick so you normally want use the
available space on the USB. As i understand isohybrid, we can create an
additional fat partition but it will be fixed to the size of the
smallest supported usb.

The reason we prefer FAT is that it makes it easy to copy apkovl to the
boot usb to and from Windows.

Also, i don't think may actually boot the ISO so we just use it as a
container, like tar.gz, but the ISO format has some advantages:
- you can boot it directly in a virtual machine
- you can 'unzip' it with 7zip and similar tools
- you can burn it (for those who actually use cdrom)

But I agree that it would be nice to make it simpler for users to
create bootable USB. I am open to ideas.

-nc

---

---

From: Sam Dodrill <[email-masked]>
Date: Tue, 19 Nov 2013 07:53:23 -0500

Unetbootin works fine, but I haven't tested it with an APKOVL, but I have
no reason to suspect it wouldn't work.

Sam Dodrill
mailto:[email-masked]