Subject: [alpine-devel] Bootable cross-build

From: "Leslie P. Polzer | PORT ZERO" <[email-masked]>
Date: Thu, 05 Dec 2013 13:27:22 +0100

Hi,

any hints on how to create an ISO that is bootable
on another architecture?

  Leslie

-- 
Dipl.Ing.(BA) Leslie P. Polzer | CTO - PORT ZERO
UG (haftungsbeschränkt)
Softwareentwicklung & IT Engineering
Adalbertstraße 7/8
10999 Berlin
Tel.: +49 (0)30 - 69 200 907 - 0
Fax: +49 (0)30 - 69 200 907 - 9
http://www.port-zero.com

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: "Leslie P. Polzer | PORT ZERO" <[email-masked]>
Date: Sun, 22 Dec 2013 17:01:24 +0100

> any hints on how to create an ISO that is bootable

To answer my own question here:

It depends largely on the board. For example the RPI
requires a binary blob as part of the booting process,
along with a configuration text file and some other
stuff.

There's also a generic bootloader called Das Uboot
which can be adjusted to run on various boards.

  Leslie

---

---

From: Timo Teras <[email-masked]>
Date: Sun, 22 Dec 2013 19:41:52 +0200

On Sun, 22 Dec 2013 17:01:24 +0100

> which can be adjusted to run on various boards.

Right. Sorry for missing the mail.

I have working script to create rpi images. I also have wandboard image
using uboot, but that is not scripted yet.

 - Timo

---