Subject: [alpine-devel] apk robustness

From: "Leslie P. Polzer | PORT ZERO" <[email-masked]>
Date: Sun, 22 Dec 2013 17:06:18 +0100

Hi,

how robust is apk? Consider a system upgrade with a couple
of packages that is interrupted by a power outage. Will it
leave the system in a sane state, guaranteed?

I think the answer is no, but I'll be happy to know more about
this.

  Leslie

-- 
Dipl.Ing.(BA) Leslie P. Polzer | CTO - PORT ZERO
UG (haftungsbeschränkt)
Softwareentwicklung & IT Engineering
Adalbertstraße 7/8
10999 Berlin
Tel.: +49 (0)30 - 69 200 907 - 0
Fax: +49 (0)30 - 69 200 907 - 9
http://www.port-zero.com

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Timo Teras <[email-masked]>
Date: Sun, 22 Dec 2013 20:46:13 +0200

On Sun, 22 Dec 2013 17:06:18 +0100

> I think the answer is no, but I'll be happy to know more about

It is not fully guaranteed. Considering apk was originally built for
the run-from-ram situation, this is not a major issue. But now that we
are having more and more run-from-harddisk setups, it might need to be
revisited.

Basically the apk database is updated only once at the end - so the
situation will be that apk thinks nothing was done, even if some
packages got updated. Next apk update will start thinking that some
packages were not updated.

So no, the apk db is not corrupted. But yes, it will not reflect the
system status exactly.

- Timo

---