Subject: [alpine-devel] libc-dev / Forcible removal of package

From: "Leslie P. Polzer | PORT ZERO" <[email-masked]>
Date: Thu, 26 Jun 2014 09:50:25 +0200

Hi folks,

excellent work with the musl port!

After upgrading to latest edge I have the following issue:

% sudo /sbin/apk fix            
(1/1) [APK unavailable, skipped] Reinstalling libc-dev (0.5-r0)
1 errors; 1871 MiB in 370 packages

I'm not sure whether libc-dev is still meant to be in world.
apk also shows that it is an empty package.

In an attempt to get rid of this empty package I tried to forcibly
remove it, but there doesn't seem to be an option to do that.
I guess this is by design?

Thanks,

  Leslie

-- 
Dipl.Ing.(BA) Leslie P. Polzer | CTO - PORT ZERO
UG (haftungsbeschränkt)
Softwareentwicklung & IT Engineering
Adalbertstraße 7/8
10999 Berlin
Tel.: +49 (0)30 - 69 200 907 - 0
Fax: +49 (0)30 - 69 200 907 - 9
http://www.port-zero.com

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Thu, 26 Jun 2014 11:37:11 +0200

On Thu, 26 Jun 2014 09:50:25 +0200

> I guess this is by design?

What happens when you do apk del libc-dev?

iirc the libc-dev is a meta package that is uspposed to pull in the correct libc headers so we don't need do:

if [ "$CLIBC" = musl ]; then depends="$depends musl-dev" ...

-nc

---

---

From: "Leslie P. Polzer | PORT ZERO" <[email-masked]>
Date: Mon, 30 Jun 2014 09:28:02 +0200

> What happens when you do apk del libc-dev?

It appears I have some deps that need it:

% sudo /sbin/apk del libc-dev
World updated, but the following packages are not removed due to:
  libc-dev: g++ build-base alpine-sdk g++-i486-alpine-linux-musl g++-armv6-alpine-linux-muslgnueabihf

The latter two are clearly packages I compiled myself. It is to be suspected
that I also built the others myself. But it is not clear to me why g++, build-base and
alpine-sdk haven't been upgraded. Or do current packages still refer to libc-dev?

Thanks for clarifying,

  Leslie

---