Subject: [alpine-devel] ipv6 network configuration problems

From: "Fr.HarryL" <[email-masked]>
Date: Thu, 3 Nov 2016 04:49:48 +0200

Hi there all !

It's been a long time!

Having downloaded the latest ISO of alpine ( 
alpine-extended-3.4.5-x86.iso )

I came across this

auto bond0
iface bond0 inet manual
   bond-slaves eth2 eth3 eth4
   bond_mode 802.3ad

auto bond0.13
iface bond0.13 inet static
   address 62.xx.xx.xx
   netmask 255.255.255.0

iface bond0.13 inet6 static
    address 2001:xxxxx
    netmask 64
    gateway 2001:xxxxx

Will always give me

vconfig: ioctl error for add: File exists
at boot time

then trying to ifdown bond0.13 from command line will complain about 
bond0.13 not being configured

needless to say ... when I've tried the same with vlan13 Naming

problems were almost the same

auto vlan13
iface vlan13 inet static
address 62.xx.xx.xx
netmask 255.255.255.0
vlan-raw-device bond0

iface vlan13 inet6 static
address 2001:470:ffff:ff::2
netmask 64
gateway 2001:470:ffff:ff::1
pre-up echo 0 > /proc/sys/net/ipv6/conf/vlan13/accept_ra

ifup vlan13 will give

run-parts: /etc/network/if-pre-up.d/vlan: exit status 1

and the ipv4 part being configured and ipv6 not, leaving the state of 
vlan13 all messed up .. :(

Your ideas will be appreciated !

Regards,

Harry.

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Johannes Matheis <[email-masked]>
Date: Thu, 10 Nov 2016 16:38:17 +0000

Hello Harry,

> vconfig: ioctl error for add: File exists

Unfortunately I have similar networking problems all over my Alpine
infrastructure … from gateways to virtualization hosts to my notebook.
I've never investigated too much as I don't reboot too often.

But I could observe an improvement after changing line 46 in my
/etc/init.d/networking from 'ifup $iface' to 'ifup -f $iface'

> vlan13 all messed up .. :(

Try:
ifup -n vlan13
That will print the steps it would do, but doesn't acually execute them.
Then try running these commands manually.

Adding 'set -x' somewhere at the beginning of 
/etc/network/if-pre-up.d/vlan
could also give some more information whats wrong.

> Your ideas will be appreciated !

Good luck!
jomat

---