Subject: [alpine-devel] Busybox causing package build problem

From: Ted Trask <[email-masked]>
Date: Fri, 11 Feb 2011 10:45:37 -0800 (PST)

I tried bumping acf-provisioning to 0.0.5 today and the build failed. It worked 
fine on my box. Checking the edge build log, it failed because of bad md5sum. 
Nenolod checked the 64-edge build box and found that the source file was an 
empty file. After deleting the source file and installing real wget, he was able 
to get the build to work. Checking on my box, I found that I had busybox-1.17.4 
installed. After upgrading my box to busybox-1.18.2, wget stopped working, 
creating an empty file. So:

1) busybox wget is broken
2) the build trees are stuck because acf-provisioning won't build

So, it would be great if someone could fix busybox wget and then unstick the 
build boxes. This means deleting the empty source packages and rebuilding. I'm 
assuming nenolod will fix build64-edge, but ncopa or fabled will probably have 
to fix both build-edge and build-2-1. (build-2-1 is broken because I forgot to 
fix the source path to include .git)

Thanks

Ted

PS. In case it matters, here are the other packages that upgraded on my box. 
wget worked before and not after the upgrade:

~$ sudo apk upgrade
Password:
(1/19) Upgrading libc0.9.32 (0.9.32_rc1-r1 -> 0.9.32_rc2-r0)
(2/19) Upgrading busybox (1.17.4-r1 -> 1.18.2-r1)
Executing busybox-1.18.2-r1.post-upgrade
(3/19) Upgrading alpine-baselayout (2.0_rc1-r1 -> 2.0_rc1-r2)
(4/19) Upgrading libcrypto1.0 (1.0.0c-r0 -> 1.0.0d-r0)
(5/19) Upgrading apk-tools (2.0.7-r5 -> 2.0.7-r6)
(6/19) Upgrading alpine-conf (2.5.5-r0 -> 2.5.5-r1)
(7/19) Upgrading bbsuid (0.5-r0 -> 0.5-r1)
(8/19) Upgrading uclibc-utils (0.9.32_rc1-r1 -> 0.9.32_rc2-r0)
(9/19) Upgrading libssl1.0 (1.0.0c-r0 -> 1.0.0d-r0)
(10/19) Upgrading openssl (1.0.0c-r0 -> 1.0.0d-r0)
(11/19) Upgrading libthread_db (0.9.32_rc1-r1 -> 0.9.32_rc2-r0)
(12/19) Upgrading uclibc-dev (0.9.32_rc1-r1 -> 0.9.32_rc2-r0)
(13/19) Upgrading git (1.7.3.5-r1 -> 1.7.4-r1)
(14/19) Upgrading mkinitfs (2.3.0-r0 -> 2.3.0-r2)
(15/19) Upgrading mtools (4.0.14-r0 -> 4.0.15-r0)
(16/19) Upgrading vim (7.3.82-r0 -> 7.3.112-r0)
(17/19) Upgrading openssl-doc (1.0.0c-r0 -> 1.0.0d-r0)
(18/19) Upgrading openssl-dev (1.0.0c-r0 -> 1.0.0d-r0)
(19/19) Upgrading perl (5.12.2-r1 -> 5.12.3-r0)
Executing busybox-1.18.2-r1.trigger
OK: 75 packages, 643 dirs, 10817 files

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: William Pitcock <[email-masked]>
Date: Fri, 11 Feb 2011 12:52:46 -0600

hi,

i've pushed busybox-1.18.2-r2 which fixes the wget problem.  this is an
upstream regression, and i've filed a bug with the patch i applied to
the alpine package.

what actually broke was handling of downloads where it took a little
bit of time to start sending the data (e.g. due to a script).

this caused read() to fail with errno=EAGAIN because in busybox 1.18.2,
wget uses non-blocking i/o.  fixing the loop to ignore EAGAIN as well
as EINTR fixed the problem entirely.

as far as getting the build boxes unstuck, bumping the acf-provisioning
package to 0.0.6 should get the job done.

william

On Fri, 11 Feb 2011 10:45:37 -0800 (PST)
Ted Trask <[email-masked]> wrote:

> I tried bumping acf-provisioning to 0.0.5 today and the build failed.
> It worked fine on my box. Checking the edge build log, it failed
> because of bad md5sum. Nenolod checked the 64-edge build box and
> found that the source file was an empty file. After deleting the
> source file and installing real wget, he was able to get the build to
> work. Checking on my box, I found that I had busybox-1.17.4
> installed. After upgrading my box to busybox-1.18.2, wget stopped
> working, creating an empty file. So:
> 
> So, it would be great if someone could fix busybox wget and then
> unstick the build boxes. This means deleting the empty source
> packages and rebuilding. I'm assuming nenolod will fix build64-edge,
> but ncopa or fabled will probably have to fix both build-edge and
> build-2-1. (build-2-1 is broken because I forgot to fix the source
> path to include .git)
> 
> Thanks
> 
> Ted
> 
> PS. In case it matters, here are the other packages that upgraded on
> my box. wget worked before and not after the upgrade:
> 
> ~$ sudo apk upgrade
> Password:

---

---

From: Ted Trask <[email-masked]>
Date: Fri, 11 Feb 2011 13:39:22 -0800 (PST)

Ok, so William patched busybox, but the build boxes were still stuck.

I updated abuild to delete source packages that fail the md5sum. The buildbox 
was still stuck on acf-provisioning because it wasn't using the new abuild I 
created.

I reverted the acf-provisioning upgrade, and that allowed a bunch of packages to 
build - abuild, busybox, and clutter.

I pushed the acf-provisioning upgrade again. The build failed due to the old 
(bad) source file. I told it to retry and it worked!

So, the edge build is working again.

Unfortunately, the 2.1 build is not. I don't dare update abuild there. ncopa or 
fabled, can you please delete the bad source file from the 2.1 builder and 
rebuild?

Thanks.

Ted

----- Original Message ----
From: William Pitcock <[email-masked]>
To: Ted Trask <[email-masked]>
Cc: Alpine Developers <[email-masked]>
Sent: Fri, February 11, 2011 1:52:46 PM
Subject: Re: [alpine-devel] Busybox causing package build problem

hi,

william

---

---

---

From: Ted Trask <[email-masked]>
Date: Fri, 11 Feb 2011 14:21:34 -0800 (PST)

Final update. The 2.1 build fixed itself. Apparently it shares a source 
directory with the edge build, because next retry it built. :)

Ted

----- Original Message ----
From: Ted Trask <[email-masked]>
To: William Pitcock <[email-masked]>
Cc: Alpine Developers <[email-masked]>
Sent: Fri, February 11, 2011 4:39:22 PM
Subject: Re: [alpine-devel] Busybox causing package build problem

Thanks.

Ted

----- Original Message ----
From: William Pitcock <[email-masked]>
To: Ted Trask <[email-masked]>
Cc: Alpine Developers <[email-masked]>
Sent: Fri, February 11, 2011 1:52:46 PM
Subject: Re: [alpine-devel] Busybox causing package build problem

hi,

william

---

---

____________________________________________________________________________________
No need to miss a message. Get email on-the-go 
with Yahoo! Mail for Mobile. Get started.
http://mobile.yahoo.com/mail 

---