Subject: Python 2

From: "Ariadne Conill" <[email-masked]>
Date: Fri, 24 Jan 2020 14:48:44 +0000

Hello,

As we know, Python 2.7 will be EOL in April, which will be
around the same time that Alpine 3.12 is branched.

Should we begin removing Python 2 in edge, or do we want to
continue supporting it for 3.12?

Ariadne

---

From: Natanael Copa <[email-masked]>
Date: Fri, 24 Jan 2020 15:52:25 +0100

On Fri, 24 Jan 2020 14:48:44 +0000

> continue supporting it for 3.12?

Would be good if we could remove it and Leo has done some good work in
that direction.

Not sure what the blockers for that is. 

Thanks!

-nc

---

From: "Ariadne Conill" <[email-masked]>
Date: Fri, 24 Jan 2020 15:03:36 +0000

Hello,

> Not sure what the blockers for that is.

I think we should identify the blockers and work them.  It
would be nice to drop Python 2 in 3.12.

Ariadne

---

From: Kevin Daudt <[email-masked]>
Date: Fri, 24 Jan 2020 21:14:57 +0100

> would be nice to drop Python 2 in 3.12.

One blocker is redo (which I maintain), which does not support python3.
I'm mostly there in porting it to python3, I'm just running into some
bugs / issues with tests failing.