Subject: [alpine-devel] configure option for gcc in APKBUILD

From: Robert Schmidt <[email-masked]>
Date: Sun, 18 Oct 2009 22:41:10 +0200

Hi,

While trying to learn how the Alpine build system works I saw that for the GCC package configure is called with "--with-arch=i486". Looking around what this option is for I got the impression that it means that the GCC uses "-march=i486" by default. Since apparently no "-march" parameter is set in APKBUILD files that results in all packages being i486 binaries. If this package was used to create Alpine 1.9.0 then this means the ISO is not i386 but i486.

Since the 386 doesn't have a FPU I would suspect that all packages that do float operations won't run on a 386. (On the other hand: who would use such a device even with a small linux?)

Did I misinterpret the whole thing?

Regards,
Robert
______________________________________________________
GRATIS für alle WEB.DE-Nutzer: Die maxdome Movie-FLAT!
Jetzt freischalten unter http://movieflat.web.de

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Mon, 19 Oct 2009 14:40:41 +0200

On Sun, 2009-10-18 at 22:41 +0200, Robert Schmidt wrote:
> Hi,
> 
> While trying to learn how the Alpine build system works I saw that for
> the GCC package configure is called with "--with-arch=i486". Looking
> around what this option is for I got the impression that it means that
> the GCC uses "-march=i486" by default. Since apparently no "-march"
> parameter is set in APKBUILD files that results in all packages being
> i486 binaries. If this package was used to create Alpine 1.9.0 then
> this means the ISO is not i386 but i486.

Yeah, you are right.

> Since the 386 doesn't have a FPU I would suspect that all packages
> that do float operations won't run on a 386. (On the other hand: who
> would use such a device even with a small linux?)
>

No. you are right. Alpine won't run on 386. FPU is one thing and there
are some CPU instructinos that was added in 486 that does not exist in
386. (cmpxchg for example)

I suppose the iso should be named x86 instead. (we are planning a x86_64
too)

-nc

---