Subject: Re: [alpine-devel] OpenVPN Multiple Tunnels

From: Steve Fink <[email-masked]>
Date: Thu, 9 Dec 2010 15:28:37 -0700 (MST)

Thank you for your response. 

I believe understand the methodology, but it is in direct contrast to the OpenVPN documented methodology. 

For example under the OpenVPN documented methodology of having the single init.d script (openvpn): 

You can issue: openvpn start and all tunnels will come up 
You can issue: openvpn stop and all tunnels will come down 
You can issue: openvpn restart and all tunnels will be restarted 
or 
You can issue: openvpn client restart and only the tunnel named client is restarted. 

Under the (I'm assuming here) Gentoo methodology of having essentially one init.d script for each tunnel you cannot start/stop/restart all of the tunnels at once you would have to issue each command separately. 

Am I correct here? 

BTW, I apologize in advance. I am not at all familiar with Gentoo, please forgive my ignorance. 

Since your initial response about OpenRC not liking the init.d script, that's where I've been digging and I believe you are correct. I am back on the trail! 

Best, 

Steve 

----- Original Message ----- 
From: "Nathan Angelacos" <[email-masked]> 
To: [email-masked] 
Sent: Thursday, December 9, 2010 3:03:15 PM 
Subject: Re: [alpine-devel] OpenVPN Multiple Tunnels 

fwiw.. 

I'm running alpinelinux 2.1.2 with multiple openvpn tunnels: 

ln -s /etc/init.d/openvpn /etc/init.d/openvpn.SanFrancisco 

rc-update add openvpn.SanFrancisco 
rc-update add openvpn 

The config files are named : 
/etc/openvpn/openvpn.conf 
/etc/openvpn/SanFrancisco.conf 

--- 
Unsubscribe: [email-masked] 
Help: [email-masked] 
---

---

From: Nathan Angelacos <[email-masked]>
Date: Thu, 09 Dec 2010 14:51:07 -0800

On 12/09/10 14:28, Steve Fink wrote:
> Under the (I'm assuming here) Gentoo methodology of having essentially
> one init.d script for each tunnel you cannot start/stop/restart all of
> the tunnels at once you would have to issue each command separately.
>
> Am I correct here?
>
In my experience, yes.

you /can/ start all tunnels with one command: "rc"
e.g.:

/etc/init.d/openvpn stop
/etc/init.d/openvpn.SanFrancisco stop

then to start them both, just run "rc"

It will find that those two are not running, though they should be for 
the current runlevel, and will start them.

But, you are correct, I haven't found a way of stopping all tunnels at 
the same time.

OTOH, 99% of the time I want to stop/modify/restart just 1 tunnel at a 
time, so it hasn't been a problem here.

> please forgive my ignorance.

NP - it was strange to me at first too.  I'm not an expert in "The 
Gentoo Way", either. :)

---