Subject: [alpine-devel] packaging help: source needs to be renamed to avoid possible collisions

From: Sven Wick <[email-masked]>
Date: Tue, 25 Dec 2018 21:44:29 +0100

Hi,

I want to create a package for Alpine
but get stuck at this error message:

  ERROR: ssh-tools: source v1.5.tar.gz needs to be renamed to avoid
possible collisions

I checked the source code of abuild
and I understand that it checks for github filenames
but I don't know how to rename the file
within the APKBUILD script or what I should do.

APKBUILD is attached

Thanks in advance

Cheers,

Sven

---

From: Milan P. Stanić <[email-masked]>
Date: Tue, 25 Dec 2018 23:43:29 +0100

> within the APKBUILD script or what I should do.

Try to prepend "$pkgname-$pkgver.tar.gz::" before source url.
source="$pkgname-$pkgver.tar.gz::https://github.com/vaporup/${pkgname}/archive/v${pkgver}.tar.gz"
add builddir variable
add subpackages

I'm attached file with changes to your APKBUILD.

-- 

> # Maintainer: Sven Wick <[email-masked]>
> 
> pkgname=ssh-tools
> pkgver=1.5
> pkgrel=1
> pkgdesc="collection of various tools using ssh"
> arch="noarch"
> url="https://github.com/vaporup/ssh-tools/"
> license="GPL"
> depends="openssh-client colordiff"
> makedepends="help2man"
> source="https://github.com/vaporup/${pkgname}/archive/v${pkgver}.tar.gz"
> md5sums="448bcf5c8c86bcef0338142d0cc477c0 v${pkgver}.tar.gz"
 
> build() {
> 	cd "$pkgname-$pkgver"
> 
>         mkdir -p "man"
> 
>         help2man -n "check if host is reachable using ssh_config"           -S SSH-TOOLS -N --version-string " " -o man/ssh-ping.1        ./ssh-ping
>         help2man -n "shows version of the SSH server you are connecting to" -S SSH-TOOLS -N --version-string " " -o man/ssh-version.1     ./ssh-version
>         help2man -n "diff a file over SSH"                                  -S SSH-TOOLS -N --version-string " " -o man/ssh-diff.1        ./ssh-diff
>         help2man -n "get some facts about the remote system"                -S SSH-TOOLS -N --version-string " " -o man/ssh-facts.1       ./ssh-facts
>         help2man -n "prints server host keys in several formats"            -S SSH-TOOLS -N --version-string " " -o man/ssh-hostkeys.1    ./ssh-hostkeys
> 
> }
> 
> package() {
> 	cd "$pkgname-$pkgver"
> 
>         mkdir -p $pkgdir/usr/share/man/man1/
> 	cp man/* $pkgdir/usr/share/man/man1/
> 
>         mkdir -p $pkgdir/usr/bin/
> 	cp ssh-* $pkgdir/usr/bin/
> }