Subject: [alpine-devel] Alpine permission bug with lbu ?

From: "Nicolas S. " <[email-masked]>
Date: Fri, 23 May 2014 14:32:06 +0200

Hello Alpine team,

I'm using the lastest stable 2.7.8 ALpineLinux on embeded hardware (like 
soekris).
On only use Alpine in ram and all is commited to a compact flash, like 
in a normal router.
I'm a little confused to ask that but it seems i found something which 
looks like a bug.

I installed the bind DNS server package, the perms are in /etc :

drwxr-x---    2 root     named          620 May 23  2014 bind

Now for a reason i need to have data sync into that dir i then change 
the perms : to 775 mode , and of course lbu commit

After reboot the perms are again as installed.
I then tried to switch the
owner:group -> same
I tried to force a lbu add /etc/bind -> same problem.

I believe it can be done with every directory from a package in /etc.

Maybe it is a noob question or not.
Can you help me or is there a workaround ?

All regards for your great work.

Nicolas.

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Fri, 23 May 2014 14:49:41 +0200

On Fri, 23 May 2014 14:32:06 +0200

> I believe it can be done with every directory from a package in /etc.

I think its apk-tools that "fixes" the permissions on the dirs when it
install the files.

> Can you help me or is there a workaround ?

a quick and dirty workaround:

cat >/etc/local.d/bind-permissions.start<<EOF
#!/bin/sh
chmod 775 /etc/bind
EOF
chmod +x /etc/local.d/bind-permissions.start
rc-service add local

---

---

From: "Nicolas S. " <[email-masked]>
Date: Fri, 23 May 2014 15:05:03 +0200

Thank you Natanael, it seems to work.
Maybe it can be a new feature for the apk-tools in the future.

Regards,

---

---

From: Timo Teräs <[email-masked]>
Date: Fri, 23 May 2014 16:15:58 +0300

> Maybe it can be a new feature for the apk-tools in the future.

Please file a bug. The permissions on overlay should override package ones. We have even code to include stuff in overlay if the only change is in permissions. This probably is regression caused by the code "merging" the directory permissions from different packages.

Thanks
Timo

---

---

From: "Nicolas S. " <[email-masked]>
Date: Sat, 24 May 2014 11:27:01 +0200

Hi Timo,

Done : Bug #2966

Regards,

Le 2014-05-23 15:15, Timo Teräs a écrit :
> Please file a bug. The permissions on overlay should override package
> ones. We have even code to include stuff in overlay if the only change
> is in permissions. This probably is regression caused by the code
> "merging" the directory permissions from different packages.
> 
> Thanks
> Timo

---