Subject: [alpine-devel] postgresql aports patch

From: Ted Trask <[email-masked]>
Date: Wed, 1 Jul 2009 13:40:48 -0700 (PDT)

I modified conf.d file to change the path.  Removed postgresql version from the path.

Ted

From 18da908616d5dc553f09b758d967a7613edc1fa7 Mon Sep 17 00:00:00 2001
From: Ted Trask <[email-masked]>
Date: Wed, 1 Jul 2009 20:38:36 +0000
Subject: [PATCH] extra/postgresql: Modified conf.d to change path to be non-version-dependent

---
 extra/postgresql/APKBUILD         |    4 ++--
 extra/postgresql/postgresql.confd |    2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/extra/postgresql/APKBUILD b/extra/postgresql/APKBUILD
index 8ab9528..fd4bdb8 100644
--- a/extra/postgresql/APKBUILD
+++ b/extra/postgresql/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Natanael Copa <[email-masked]>
 pkgname=postgresql
 pkgver=8.3.7
-pkgrel=1
+pkgrel=2
 pkgdesc="A sophisticated object-relational DBMS"
 url="http://www.postgresql.org/"
 license="BSD"
@@ -47,4 +47,4 @@ client() {
 
 md5sums="7b7e91a2221e55fe1b167e663217a96d  postgresql-8.3.7.tar.bz2
 7ed7e95246798ac3d5474ed12bf98e98  postgresql.initd
-ea3320c56a22f5c305199886c2766387  postgresql.confd"
+8c0f33f53ccb1bfd7b03aef823513170  postgresql.confd"
diff --git a/extra/postgresql/postgresql.confd b/extra/postgresql/postgresql.confd
index 56561b0..af2472a 100644
--- a/extra/postgresql/postgresql.confd
+++ b/extra/postgresql/postgresql.confd
@@ -1,5 +1,5 @@
 # PostgreSQL's Database Directory
-PGDATA="/var/lib/postgresql/8.3/data"
+PGDATA="/var/lib/postgresql/data"
 
 # PostgreSQL User
 PGUSER="postgres"
-- 
1.6.3.3

---

From: Natanael Copa <[email-masked]>
Date: Fri, 03 Jul 2009 09:39:05 +0200

> I modified conf.d file to change the path.  Removed postgresql version from the path.
For the record. this should not be applied. I think we want the
postgresql version in the path in default config to make future upgrades
easier. Aslo, this is a config option so you should not hardcode this
calue any place in ACF, but instead, you should parse this value.

thanks!

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---