Subject: [alpine-devel] extra/grep

From: Michael Mason <[email-masked]>
Date: Thu, 5 Mar 2009 21:32:12 +0000

Please review.
Working on some of the packages in the list:
http://dev.alpinelinux.org/~ncopa/alpine/pkg-todo.txt

---

From: Natanael Copa <[email-masked]>
Date: Fri, 06 Mar 2009 15:56:57 +0100

> http://dev.alpinelinux.org/~ncopa/alpine/pkg-todo.txt

Maybe we should try get the acf-* files done?

In file included from esearch.c:2:
search.c:44:19: error: pcre.h: No such file or directory
In file included from esearch.c:2:
search.c: In function 'check_multibyte_string':

looks like it needs pcre.

(after adding pcre-dev to makedepends:)

nclab01:~/aports/extra/grep$ scanelf -Rn pkg
 TYPE   NEEDED FILE 
ET_DYN libpcre.so.0,libc.so.0,ld-uClibc.so.0 pkg/usr/bin/grep 

we need pcre in depends (it provides libpcre.so.0)

I added those and committed.

Thanks!

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---