Subject: [alpine-devel] Full disk encryption with musl edge

From: [email-masked]
Date: Sun, 20 Apr 2014 15:50:40 -0400

I recently upgraded to musl edge using the instructions at alpinelinux.org/edge-musl. When I reboot, I get the prompt to enter my passphrase for the disk but when I enter it it'll say "mounting root failed", "initramfs emergency recovery shell launched. Type exit to continue boot", "sh: can't access tty; job control turned off".

"Mount: mounting /dev/mapper/vg0-root on /sysroot failed: no such file or directory"
Shows up in file /tmp/mount-error in the emergency shell.

Has this happened to anyone else? How can this be fixed?

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Timo Teras <[email-masked]>
Date: Tue, 22 Apr 2014 16:36:25 +0300

On Sun, 20 Apr 2014 15:50:40 -0400
[email-masked] wrote:

> I recently upgraded to musl edge using the instructions at
> alpinelinux.org/edge-musl. When I reboot, I get the prompt to enter
> my passphrase for the disk but when I enter it it'll say "mounting
> root failed", "initramfs emergency recovery shell launched. Type exit
> to continue boot", "sh: can't access tty; job control turned off".
> 
> "Mount: mounting /dev/mapper/vg0-root on /sysroot failed: no such
> file or directory" Shows up in file /tmp/mount-error in the emergency
> shell.
> 

What tools / packages you have used to setup this? Do you get any other
errors in dmesg? If you try to mount the encrypted partition manually,
do you get additional errors?

---