Subject: [alpine-devel] new ports: par2cmdline; py-cheetah, py-feedparser, py-yenc and pyopenssl

From: lonkaji <[email-masked]>
Date: Wed, 5 Jan 2011 22:21:53 +0100

GIT: [PATCH 2/6] new port: par2cmdline
GIT: [PATCH 3/6] new port: python-cheetah
GIT: [PATCH 4/6] new port: python-feedparser
GIT: [PATCH 5/6] new port: python-yenc
GIT: [PATCH 6/6] new port: pyopenssl

Hi,
I've made some new patchs.
Please review it.

I've try to send a email using git but I still have this error:
*From: Kalonji <[email-masked]>
To: [email-masked]
Subject: new ports: par2cmdline; py-cheetah, py-feedparser, py-yenc and
pyopenssl
Date: Wed,  5 Jan 2011 21:16:23 +0000
Message-Id: <[email-masked]>
X-Mailer: git-send-email 1.7.3.2

Send this email? ([y]es|[n]o|[q]uit|[a]ll): all
5.5.1 Authentication Required. Learn more at
5.5.1 http://mail.google.com/support/bin/answer.py?answer=14257m10sm16260598wbc.16
git: 'send-email' is not a git command. See 'git --help'.

Did you mean this?*

I already got git, git-perl and perl sasl and ssl packages.
If anybody know why I got this error, please let me know.
Thanks.

---

From: Natanael Copa <[email-masked]>
Date: Thu, 6 Jan 2011 14:15:56 +0100

On Wed, 5 Jan 2011 22:21:53 +0100
lonkaji <[email-masked]> wrote:

> 5.5.1
> http://mail.google.com/support/bin/answer.py?answer=14257m10sm16260598wbc.16

see this on how to use gmail with git send-email:

http://morefedora.blogspot.com/2009/02/configuring-git-send-email-to-use-gmail.html

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Thu, 6 Jan 2011 17:35:20 +0100

> I've made some new patchs.

I'm looking at them now.

Is it correct that there should be no 1/6?

-nc

---

---

From: Natanael Copa <[email-masked]>
Date: Thu, 6 Jan 2011 17:48:07 +0100

On Wed, 5 Jan 2011 22:21:53 +0100
lonkaji <[email-masked]> wrote:

> From 636d4dcd41014c5b6e8e0f045cf810b455ed626b Mon Sep 17 00:00:00 2001
> From: Kalonji <[email-masked]>
> Date: Wed, 5 Jan 2011 20:51:53 +0000
> Subject: [PATCH 2/6] new port: par2cmdline
> 
> ---
>  testing/par2cmdline/APKBUILD                       |   52 +++++
>  testing/par2cmdline/par2cmdline-0.4-autoconf.patch |   22 ++
>  testing/par2cmdline/par2cmdline-0.4-cosmetic.patch |  106 ++++++++++
>  testing/par2cmdline/par2cmdline-0.4-gcc4.patch     |   62 ++++++
>  .../par2cmdline/par2cmdline-0.4-hardlinks.patch    |   15 ++
>  testing/par2cmdline/par2cmdline-0.4-letype.patch   |  219
> ++++++++++++++++++++
> testing/par2cmdline/par2cmdline-0.4-offset.patch   |   16
> ++ .../par2cmdline/par2cmdline-0.4-wildcard-fix.patch |   23 ++ 8
> files changed, 515 insertions(+), 0 deletions(-) create mode 100644
> testing/par2cmdline/APKBUILD create mode 100644
> testing/par2cmdline/par2cmdline-0.4-autoconf.patch create mode 100644
> testing/par2cmdline/par2cmdline-0.4-cosmetic.patch create mode 100644
> testing/par2cmdline/par2cmdline-0.4-gcc4.patch create mode 100644
> testing/par2cmdline/par2cmdline-0.4-hardlinks.patch create mode
> 100644 testing/par2cmdline/par2cmdline-0.4-letype.patch create mode
> 100644 testing/par2cmdline/par2cmdline-0.4-offset.patch create mode
> 100644 testing/par2cmdline/par2cmdline-0.4-wildcard-fix.patch
> 
> diff --git a/testing/par2cmdline/APKBUILD
> b/testing/par2cmdline/APKBUILD new file mode 100644
> index 0000000..7c6cbb3
> --- /dev/null
> +++ b/testing/par2cmdline/APKBUILD
> @@ -0,0 +1,52 @@
> +# Contributor: <[email-masked]>
> +# Maintainer: <[email-masked]>
> +pkgname=par2cmdline
> +pkgver=0.4
> +pkgrel=1

Start with pkgrel=0 on first release.

> +pkgdesc="Providing a tool to apply the data-recovery capability
> concepts of RAID-like systems to the posting & recovery of multi-part
> archives on Usenet." 

Would have been nice with a shorter pkgdesc.

> +url="http://sourceforge.net/projects/parchive/"
> +license="GPL"

arch="all"

was missing.

> +depends=
> +makedepends=
> +install=
> +source="http://downloads.sourceforge.net/sourceforge/parchive/${pkgname}-${pkgver}.tar.gz
> +par2cmdline-0.4-autoconf.patch
> +par2cmdline-0.4-letype.patch
> +par2cmdline-0.4-cosmetic.patch
> +par2cmdline-0.4-offset.patch
> +par2cmdline-0.4-gcc4.patch
> +par2cmdline-0.4-wildcard-fix.patch
> +par2cmdline-0.4-hardlinks.patch"
> +
> +_builddir="$srcdir"/$pkgname-$pkgver
> +
> +prepare() {
> +	cd "$_builddir"
> +		for i in "$srcdir"/*.patch; do
> +			msg "Applying ${i}"
> +				patch -N -i $i || return 1
> +				done
> +}

Indentation is weird.

> +
> +build() {
> +	cd "$_builddir"
> +		./configure --prefix=/usr \
> +		--sysconfdir=/etc \
> +		--mandir=/usr/share/man \
> +		--infodir=/usr/share/info
> +		make || return 1

indentation...

> +}
> +
> +package() {
> +	cd "$_builddir"
> +		make DESTDIR="$pkgdir" install

also here

I applied and fixed the above. (except for pkgrel)

Thanks!

-nc

---

---

From: Natanael Copa <[email-masked]>
Date: Thu, 6 Jan 2011 17:59:04 +0100

> GIT: [PATCH 2/6] new port: par2cmdline

the above was applied as mentioned.

> GIT: [PATCH 6/6] new port: pyopenssl

Those have all "wrong" pkgname.

See http://alpinelinux.org/wiki/Package_policies

Should be:
py-cheetah
py-feedparser
py-yenc
py-openssl

Care to fix that and then resend them as new commits?

Something like:

cd testing/
git reset HEAD~3	# undo last 3 commits, now python-cheetah is
			# latest commit.
git mv python-cheetah py-cheetah
git commit --amend	# redo the last commit but in new dir
vim py-cheetah/APKBUILD  # change pkgname and fix _builddir etc
git add py-cheetah/APKBUILD
git commit --amend	# redo the last commit with latest change

rm -r python-feedparser
git am ~/0004-new-port-python-feedparser.patch # re-apply
# do similar git mv and --amend as above
# do same with the rest

# send to ml
git send-email --to [email-masked] HEAD~4 

Something like that...

-nc

---