Subject: [alpine-devel] Upcomming feature freeze for alpine 2.0.0

From: Natanael Copa <[email-masked]>
Date: Thu, 3 Jun 2010 10:41:14 +0200

Hi,

I think now is a good time to go for a stable alpine-2.0:
* We have the most big, critical new stuff in (uclibc-nptl, openssl-1.0)
* ntpl fixes some issues thats non-fixeable in older uclibc. Affects
freeswitch, vlc and others.
* I'd like join the ubuntu rythm for time based releases (every april,
october) so rather than wait all way to oct we release 2.0 now and 2.1
in oct (or 1 nov).
* even developers need something stable to develop on

So basicly, I'd like to take what we have, tie up some loose ends,
ship alpine-2.0 rc1/beta1, work on the 2.0 release for the nearest
days/weeks and ship 2.0.

This means we need start draw the limit what goes in 2.0 and what will
wait for 2.1. All packages in 'testing' will be re-moved from 2.0
branch (like we did in 1.10 - we dont ship things that needs testing).
The list is below.

If there is something you really want go into 2.0, then please give it
a test spin asap, fix whatever needs fixing and report back that it
works and can be moved to 'main'. The stuff we dont have time to
include will not be included.

The packages I'm talking about are (* means I will personally have a
look at it):

acf-fetch-crl
acl
alsa-utils*
asterisk-audio-konf
atomic-ops
backuppc
bacula
bacula-client
bluez
bluez-firmware
bluez-hcidump
cdparanoia
cherokee
collectd
coova-chilli
cryptsetup
daemontools
dspam
ebtables*
ferm
fetch-crl
freeradius
fuse
gdl
geh*
gnumeric*
gnump3d
gross-svn
gtksourceview
gtkspell
haproxy
hardinfo
hdparm
hping3
html2ps
icecast
iproute2* (with xfrm patches)
ircii
ircservices
iscsi-scst
iscsi-scst-grsec
iscsi-scst-svn
ivtv-utils
kamailio
knock
kqemu-grsec
libaio
libelf
libgssglue
libical
libnetfilter_log
libtirpc
libwmf
linux-scst
live-media
ltrace
lua-crypto
lua-curl
lua-filesystem
lua-nixio
lua-penlight
lua-rexlib
lua-stdlib
madwimax
mediaproxy
mp3info
mtx
multipath-tools
nagios
obexd
open-iscsi
open-iscsi-grsec
openobex
opensips
opensips-cp
openxcap
osmo*
pekwm*
perl-carp-clan
perl-date-format
perl-date-manip
perl-devel-symdump
perl-file-tail
perl-pod-coverage
perl-sub-uplevel
perl-test-exception
perl-test-inter
perl-test-pod-coverage
perl-yaml-syck
pllua
pmacct
pptpclient
privoxy
prosody
py-application
py-buildutils
py-cjson
py-crypto
py-genshi
py-gnutls
py-imaging
py-lxml
py-mysqldb
py-setuptools
py-sqlite
py-twisted
py-twisted-web2
py-zope-interface
rrdbot
rrdcollect
rtapd
rtnppd
scst-grsec
scst-svn-scst
scstadmin-svn
sems
sircbot*
sisctrl
smartmontools*
spandsp
swatch
swish-e
tcpflow
thunar-media-tags-plugin*
trac
ttf-linux-libertine*
ucspi-tcp
udev
ulogd
umix
valide
xmlrpc-c

-- 
Natanael Copa

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Nathan Angelacos <[email-masked]>
Date: Fri, 04 Jun 2010 12:48:30 -0700

> collectd
(1/1) Installing collectd (4.9.1-r2)

Daemon starts; no init.d script yet

> cryptsetup
#apk add cryptsetup
(1/5) Installing device-mapper (2.02.66-r0)
(2/5) Installing libgpg-error (1.7-r1)
(3/5) Installing libgcrypt (1.4.5-r1)
(4/5) Installing popt (1.16-r0)
(5/5) Installing cryptsetup (1.1.0-r0)
Tested and works

> ferm
(1/3) Installing perl (5.10.1-r1)
(2/3) Installing iptables (1.4.7-r1)
(3/3) Installing ferm (2.0.5-r0)

No init.d script; but works.

> kamailio

(1/3) Installing confuse (2.7-r0)
(2/3) Installing libxml2 (2.7.7-r0)
(3/3) Installing kamailio (3.0.2-r0)

kamailio.cfg is in /usr/etc/kamailio.cfg ?!  Needs fixing

Everything in /usr/etc/kamailio/* needs to go to /etc/kamailio/*
Not ready yet

> sems
apk add sems
(1/5) Installing confuse (2.7-r0)
(2/5) Installing libxml2 (2.7.7-r0)
(3/5) Installing kamailio (3.0.2-r0)
(4/5) Installing lame (3.98.4-r0)
(5/5) Installing sems (1.2.1-r0)

issue: kamailio and lame should not be dependencies
issue: #sems
	configuration file:  /usr/local/etc/sems/sems.conf
         plug-in path:        /usr/local/lib/sems/plug-in

	but the conf is in /etc/sems/sems.conf
         plugins are in /usr/lib/sems

Does work using: #sems -f /etc/sems/sems.conf
No init.d script yet (not a blocker)

works

> umix
(1/1) Installing umix (1.0.2-r1)

modprobe snd-oss-mixer && umix
works

---

---

From: Natanael Copa <[email-masked]>
Date: Fri, 4 Jun 2010 20:59:15 +0000

> Daemon starts; no init.d script yet

so this needs to be done.

> (5/5) Installing cryptsetup (1.1.0-r0)

i suppose we can ship it without support from init scripts? (mounting
encrypted devices during boot)

gentoo scripts look a bit overly complicated.

I suppose we can move it to main anways.
moved.

> No init.d script; but works.

do we need that? will not /etc/init.d/iptables save do the job?

moved to main.

> kamailio.cfg is in /usr/etc/kamailio.cfg ?!  Needs fixing

ugh. yes.

> Everything in /usr/etc/kamailio/* needs to go to /etc/kamailio/*

yes

> issue: kamailio and lame should not be dependencies

lame is pulled in since usr/lib/sems/plug-in/mp3.so is linked to it.
If this is a proble we need so make a subpackage called sems-mp3 or
somtehing.

kamailio was manually added to depends.

>        plug-in path:        /usr/local/lib/sems/plug-in

ugh.. this needs fixing

> No init.d script yet (not a blocker)

does sems need to create a user for the daemon?

Francesco, care to have a look at this? (you are maintainer)

> modprobe snd-oss-mixer && umix

moved to main.

Thanks!

-- 
Natanael Copa

---

---

From: Nathan Angelacos <[email-masked]>
Date: Fri, 04 Jun 2010 14:46:28 -0700

On 06/04/10 13:59, Natanael Copa wrote:
> On Fri, Jun 4, 2010 at 7:48 PM, Nathan Angelacos<[email-masked]>  wrote:

Attached is a init script; however, there's a few things that could be 
fixed:

Config file is /etc/collectd.conf
	recommend /etc/collectd/collectd.conf

PID file is /usr/var/run/collectd.pid
	recommend /var/run/collectd.pid

Logging/collection dir is /usr/var/lib/collectd/
	recommend /var/lib/collectd/

Also, the "network.so" module is loaded in the default collectd.conf, 
but is not included in the package.  network.so allows collectd to 
send/receive logging data across the network - Should be included in the 
package, or the collectd.conf should not load the module.

---

From: Nathan Angelacos <[email-masked]>
Date: Fri, 04 Jun 2010 14:49:49 -0700

> package, or the collectd.conf should not load the module.

whoops... User error

#apk add collectd-network

fixes the problem.

---

---

From: Natanael Copa <[email-masked]>
Date: Fri, 4 Jun 2010 22:15:16 +0000

>        recommend /var/lib/collectd/

This is exactly why things go into testing first. Yes we want fix those.

> Also, the "network.so" module is loaded in the default collectd.conf, but is
> not included in the package.  network.so allows collectd to send/receive
> logging data across the network - Should be included in the package, or the
> collectd.conf should not load the module.

I think we want comment out the network module from default config then.

Will look at the init.d script monday.

Thanks!

-- 
Natanael Copa

---

---

From: Francesco <[email-masked]>
Date: Sat, 5 Jun 2010 00:19:51 +0200

You want sems running with a user...but sems need to be setuid.

Two solutions:

1. Running as root (ugly)
2. Make a simple sems.pre-install script that create sems users and set it
to suid.

What do you think?

:: Francesco Colista
:: Email : [email-masked]
:: Jabber: [email-masked]

2010/6/5 Natanael Copa <[email-masked]>

> Unsubscribe:  [email-masked]<[email-masked]>
> Help:         [email-masked]<[email-masked]>
> ---
>
>

---

From: Natanael Copa <[email-masked]>
Date: Sat, 5 Jun 2010 15:16:25 +0000

> You want sems running with a user...but sems need to be setuid.

why? what does it need root permissions for?

> 1. Running as root (ugly)

if it needs root then let us run it as root.

> 2. Make a simple sems.pre-install script that create sems users and set it

I'd like figure out why it needs root and see if its solvable.
otherwise we can probably just run it as root.

>> > but is

-- 
Natanael Copa

---

---

From: Natanael Copa <[email-masked]>
Date: Thu, 24 Jun 2010 11:34:50 +0200

> 	recommend /etc/collectd/collectd.conf

fixed.

> 	recommend /var/run/collectd.pid

fixed.

> 	recommend /var/lib/collectd/

fixed.

> package, or the collectd.conf should not load the module.

fixed. commented out the module from default conf.

And moved to main. Thanks!

-- 
Natanael Copa

---

---

From: Nathan Angelacos <[email-masked]>
Date: Fri, 04 Jun 2010 14:24:56 -0700

Just fyi:

None of the iscsi targets (scst or iet) seem to ship with modules for 
linux-vs (vserver).

---