Subject: [alpine-devel] testing/libtiff

From: Michael Mason <[email-masked]>
Date: Fri, 20 Feb 2009 21:51:25 +0000

Please add.
Trying to get hylafax and iaxmodem working. They need this.

---

From: Natanael Copa <[email-masked]>
Date: Mon, 23 Feb 2009 14:05:44 +0100

> Trying to get hylafax and iaxmodem working. They need this.

cool! the install file was missing so I cannot commit.

Care to send a new/aditional patch? that corrects?
Please see comments below.

> 
> 
> 
> 
> 
> 
> differences
> between files
> attachment
> (0001-libtiff-for-alpine-linux.patch)
> 
> From 3c77756598d2603e37a391b93b8705db598b8751 Mon Sep 17 00:00:00 2001
> From: ms13sp <[email-masked]>
> Date: Fri, 20 Feb 2009 19:41:29 +0000
> Subject: [PATCH] libtiff for alpine linux
> 
> ---
>  testing/libtiff/APKBUILD |   36 ++++++++++++++++++++++++++++++++++++
>  1 files changed, 36 insertions(+), 0 deletions(-)
>  create mode 100644 testing/libtiff/APKBUILD
> 
> diff --git a/testing/libtiff/APKBUILD b/testing/libtiff/APKBUILD
> new file mode 100644
> index 0000000..44776e8
> --- /dev/null
> +++ b/testing/libtiff/APKBUILD
> @@ -0,0 +1,36 @@
> +# Contributor: Ms13sp <[email-masked]>
> +# Maintainer: Ms13sp <[email-masked]>
> +pkgname=libtiff
> +pkgshort=tiff

generally, I try to use the same package name as the source package. I
think this pkgname should be "tiff". I checked up what gentoo did. They
call it "tiff".

> +pkgver=3.8.2
> +pkgrel=0
> +pkgdesc="Provides support for the Tag Image File Format or TIFF"
> +url="http://www.libtiff.org/"
> +license="GPL"
> +depends=""
> +makedepends="uclibc++-dev"

if you need uclibc++-dev you almost always need to add uclibc++ to
depends as well. run 'scanelf -Rn pkg' and see if any files are linked
against uclibc++ and add uclibc++ to depends.

That said, gentoo have a useflag for nocxx so I think you can disable
the c++ stuff. Probably with ./configure --disable-cxx or similar.

I suggest that you disable c++ libs unless you really need them.

> +install="libtiff.install"

this file is needed to build the package but was exculded from the
patch. I cannot commit as it would break the building.

> +subpackages="$pkgname-doc $pkgname-dev"
> +source="ftp://ftp.remotesensing.org/pub/$pkgname/$pkgshort-$pkgver.tar.gz
> +       $install
> +       "
> +
> +build() {
> +       cd "$srcdir/$pkgshort-$pkgver"
> +
> +       export CXX="g++-uc"

This is the "correct" way to get your stuff linked to uclibc++ rather
than gnu g++. Very well.

> +       ./configure --prefix=/usr \
> +               --sysconfdir=/etc \
> +               --mandir=/usr/share/man \
> +               --infodir=/usr/share/info

As mentioned above, check if you can add --disable-cxx or similar here.

> +       make || return 1
> +       make DESTDIR="$pkgdir" install
> +
> +       # install -m755 -D "$srcdir"/$pkgname.initd
> "$pkgdir"/etc/init.d/$pkgname
> +       # install -m644 -D "$srcdir"/$pkgname.confd
> "$pkgdir"/etc/conf.d/$pkgname

dead code. they only waste space ;)

> +}
> +
> +md5sums="fbb6f446ea4ed18955e2714934e5b698  tiff-3.8.2.tar.gz
> +b730b3d200f52027868378ad5ee0226b  libtiff.install"

> -- 
> 1.6.1.3

Thanks!

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---