Subject: [alpine-devel]

From: Fredrik Paulsson <[email-masked]>
Date: Sun, 5 Jan 2014 14:22:59 +0100

Hi,

Trying to develop/build two new APK packages libftdi and telldus-core (home
automation) by using the guides on the wiki and Alpine Linux 2.7.2.

I have a chroot-environment and managed to build the packages in
$HOME/aports. Copied the packages together with APKINDEX from
$HOME/packages to a usb-stick.

Installed the packages on another alpine linux system (2.7.2) and also made
'lbu commit', still they don't appear after reboot!?

My guess is that /etc/apk/world is blocking them:

libftdi-compat><Q14q0JoVME9CJeH9I0Fk/Hh2pMUQQ=
telldus-core><Q1xI9XaVaXUEkNZm7YPxZfdpVjwCA=

Why is '<>' added during installation?

Thanks for any help,
frepa - new on alpine linux

---

From: Ted Trask <[email-masked]>
Date: Mon, 6 Jan 2014 08:58:27 -0500

The >< indicates that the package is locked to a particular version. That happens any time you install a package from an apk file rather from a repository. You can remove that info from the end of the line if you would like to upgrade the package to match the latest in the repo. This will not solve your problem, however. The package is not installed on a reboot because apk cannot find the package. Try creating a local cache: http://wiki.alpinelinux.org/wiki/Local_APK_cache

Ted

On Jan 5, 2014, at 8:22 AM, Fredrik Paulsson <[email-masked]> wrote:

> Hi,
> 
> Trying to develop/build two new APK packages libftdi and telldus-core (home automation) by using the guides on the wiki and Alpine Linux 2.7.2.
> 
> I have a chroot-environment and managed to build the packages in $HOME/aports. Copied the packages together with APKINDEX from $HOME/packages to a usb-stick.
> 
> Installed the packages on another alpine linux system (2.7.2) and also made 'lbu commit', still they don't appear after reboot!?
> 
> --- Unsubscribe: [email-masked] Help: [email-masked] ---

---

From: Fredrik Paulsson <[email-masked]>
Date: Mon, 6 Jan 2014 15:15:04 +0100

Thanks for the explanation of '><'!

I have already ran the setup_alpine script and I have a cache. If I make
'ls' of /etc/apk/cache I get the following:

APKINDEX.9bca125c.tar.gz
APKINDEX.f9100962.tar.gz
installed
libusb-compat-0.1.5-r2.a416bcbd.apk
libcrypto1.0-1.0.1e-r5.f1011226.apk
telldus-core-2.1.1-r1.c48f5769.apk
libftdi-compat-0.20-r1.e2ad09a1.apk

Clearly my own apk:s telldus-core and libftdi are there.

What I find strange is that they are not referenced inside any APKINDEX
file of the cache?

Cheers,
Frepa

2014/1/6 Ted Trask <[email-masked]>

> The >< indicates that the package is locked to a particular version. That
> happens any time you install a package from an apk file rather from a
> repository. You can remove that info from the end of the line if you would
> like to upgrade the package to match the latest in the repo. This will not
> solve your problem, however. The package is not installed on a reboot
> because apk cannot find the package. Try creating a local cache:
> http://wiki.alpinelinux.org/wiki/Local_APK_cache
>
> Ted
>
> Trying to develop/build two new APK packages libftdi and telldus-core
> (home automation) by using the guides on the wiki and Alpine Linux 2.7.2.
>
> Installed the packages on another alpine linux system (2.7.2) and also
> made 'lbu commit', still they don't appear after reboot!?
>
> --- Unsubscribe: [email-masked] Help:
> [email-masked] ---
>
>

---

From: Fredrik Paulsson <[email-masked]>
Date: Thu, 9 Jan 2014 21:57:52 +0100

Changed my /etc/apk/world from

to

libftdi-compat
telldus-core

Still the apk-packages are *not* installed in RAM although my cache looks
like:

APKINDEX.0f59c441.tar.gz
APKINDEX.9bca125c.tar.gz
installed

Tried to install python using apk but receives the following response:

> apk add python
ERROR: unsatisfiable constraints:
  libftdi-compat (missing):
    required by: world[libftdi-compat]
  telldus-core (missing):
    required by: world[telldus-core]

How do I install my built packages from $HOME/aports on another system in a
correct way?

I thought it was just to run the following:

>setup-alpine
>cp my_public_key /etc/apk/keys/.
>apk add <path>/<mybuiltpackage.apk>

Cheers,
Frepa

2014/1/6 Fredrik Paulsson <[email-masked]>