Subject: [alpine-devel] Captive portal

From: Mohsen Ahmadian <[email-masked]>
Date: Sun, 29 Jan 2012 22:50:25 +0330

Hello
I want to install a captive portal in my alpine gateway box .i searched for
an opensource of the captive portal and find coova-chilli is an open source
captive portal b but when i try to compile it, i Have this Error please
help me! or choose better captive portal Thank you

Error :
checking how to run the C preprocessor... /lib/cpp
configure: error: in `/root/coova-chilli-1.2.9':
configure: error: C preprocessor "/lib/cpp" fails sanity check

-- 
------------------------------------------------------------------------------------------------------------------
If you have a great project you will have huge errors

---

From: Francesco Colista <[email-masked]>
Date: Sun, 29 Jan 2012 22:05:24 +0100

Il 29.01.2012 20:20 Mohsen Ahmadian ha scritto:
> Hello
>  I want to install a captive portal in my alpine gateway box .i
> searched for an opensource of the captive portal and find 
> coova-chilli
> is an open source captive portal b but when i try to compile it, i
> Have this Error please help me! or choose better captive portal Thank
> you
>
> Error :
> configure: error: in `/root/coova-chilli-1.2.9:

Hi Mohsen.
Coova chilli is already packaged in alpine, so you don't need to 
compile it.
apk add coova-chilli.

If you need the 1.2.9 version, tomorrow we will push the new package.
I'm using it in production and, until now (after 2 weeks), seems to 
work correctly.

If you want to compile it by yourselves, be sure that you have 
installed alpine-sdk.

Let us know, bye.

-- 
:: Francesco ::
Blog: http://fc1979.blogspot.com
Jabber: [email-masked]
E-Mail: [email-masked]
GnuPG: FE9DDD5F

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---