Subject: [alpine-devel] wine: update to 1.3.28 (PATCH)

From: Austin English <[email-masked]>
Date: Mon, 12 Sep 2011 05:01:02 -0500

Howdy,

The latest update of Wine no longer needs patches to build on Alpine Linux:
http://source.winehq.org/git/wine.git/commitdiff/9e50294f2391a63d9b3819f7c0f7d40e8aaf61a2
http://source.winehq.org/git/wine.git/commitdiff/4cddd5ffdf0c568445365c6c62e7788d7dbbca7d

While updating the package, I also removed a duplicate dependency
listing for fontconfig-dev and removed a couple deprecated items in
the build function (make depend hasn't been needed for a long time,
and wine hasn't put files in /etc for years.

If those should be separate patches, please let me know.

Please CC me on replies, I'm not subscribed to this list.

Cheers,
Austin
From 45a3d038be7f6dda793959f1d9f63af9db42032a Mon Sep 17 00:00:00 2001
From: Austin English <[email-masked]>
Date: Mon, 12 Sep 2011 04:54:56 -0500
Subject: [PATCH] wine: update to 1.3.28

---
 main/wine/APKBUILD                 |   13 +++--------
 main/wine/dn_skipname.patch        |   38 ------------------------------------
 main/wine/uclibc-fmaxf-fminf.patch |   21 -------------------
 3 files changed, 4 insertions(+), 68 deletions(-)
 delete mode 100644 main/wine/dn_skipname.patch
 delete mode 100644 main/wine/uclibc-fmaxf-fminf.patch

diff --git a/main/wine/APKBUILD b/main/wine/APKBUILD
index 6b31e8e..7b4dbfd 100644
--- a/main/wine/APKBUILD
+++ b/main/wine/APKBUILD
@@ -1,6 +1,6 @@
 # Maintainer: Natanael Copa <[email-masked]>
 pkgname=wine
-pkgver=1.3.27
+pkgver=1.3.28
 pkgrel=0
 pkgdesc="A compatibility layer for running Windows programs"
 url="http://www.winehq.com"
@@ -11,12 +11,10 @@ makedepends="fontconfig-dev openldap-dev libxslt-dev libxxf86dga-dev
 	libxcursor-dev libxrandr-dev libxdamage-dev mesa-dev flex bison
 	libpng-dev jpeg-dev freetype-dev ncurses-dev openssl-dev
 	libxcomposite-dev libxrender-dev libxinerama-dev zlib-dev
-	fontconfig-dev cups-dev alsa-lib-dev lcms-dev libxml2-dev
+	cups-dev alsa-lib-dev lcms-dev libxml2-dev
 	gstreamer-dev gst-plugins-base-dev paxctl
 	autoconf automake"
 source="http://ibiblio.org/pub/linux/system/emulators/$pkgname/$pkgname-$pkgver.tar.bz2
-	dn_skipname.patch
-	uclibc-fmaxf-fminf.patch
 	"
 
 _builddir="$srcdir"/$pkgname-$pkgver
@@ -36,9 +34,8 @@ prepare() {
 build() {
 	cd "$_builddir"
 	./configure --prefix=/usr \
-		--sysconfdir=/etc/wine \
 		--with-x
-	make depend && make 
+	make 
 }
 
 package() {
@@ -49,6 +46,4 @@ package() {
 		"$pkgdir"/usr/bin/wine
 }
 
-md5sums="d717ecec6959d8cab194c61c29c3dcdf  wine-1.3.27.tar.bz2
-6ebeaa64eddf97be3267db236ce84b71  dn_skipname.patch
-1127b41caf4de8f567b9a3d0aff5277f  uclibc-fmaxf-fminf.patch"
+md5sums="d717ecec6959d8cab194c61c29c3dcdf  wine-1.3.27.tar.bz2"
diff --git a/main/wine/dn_skipname.patch b/main/wine/dn_skipname.patch
deleted file mode 100644
index 99ecf83..0000000
--- a/main/wine/dn_skipname.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- ./dlls/dnsapi/ns_parse.c.orig
-+++ ./dlls/dnsapi/ns_parse.c
-@@ -69,6 +69,35 @@
- } while (0)
- 
- /* Public. */
-+#ifdef __UCLIBC__
-+int
-+dn_skipname(const u_char *comp_dn, const u_char *eom)
-+{
-+       const u_char *cp;
-+       int n;
-+
-+       cp = comp_dn;
-+       while (cp < eom && (n = *cp++)) {
-+               /*
-+                * check for indirection
-+                */
-+               switch (n & INDIR_MASK) {
-+               case 0:                 /* normal case, n == len */
-+                       cp += n;
-+                       continue;
-+               case INDIR_MASK:        /* indirection */
-+                       cp++;
-+                       break;
-+               default:                /* illegal type */
-+                       return (-1);
-+               }
-+               break;
-+       }
-+       if (cp > eom)
-+               return (-1);
-+       return (cp - comp_dn);
-+}
-+#endif
- 
- static int
- dns_ns_skiprr(const u_char *ptr, const u_char *eom, ns_sect section, int count) {
diff --git a/main/wine/uclibc-fmaxf-fminf.patch b/main/wine/uclibc-fmaxf-fminf.patch
deleted file mode 100644
index 1f26cb8..0000000
--- a/main/wine/uclibc-fmaxf-fminf.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- ./dlls/d3dx9_36/mesh.c.orig
-+++ ./dlls/d3dx9_36/mesh.c
-@@ -40,6 +40,18 @@
- #include "wine/list.h"
- #include "d3dx9_36_private.h"
- 
-+#ifdef __UCLIBC__
-+float fmaxf(float a, float b)
-+{
-+	return (a > b) ? a : b;
-+}
-+
-+float fminf(float a, float b)
-+{
-+	return (a < b) ? a : b;
-+}
-+#endif
-+
- WINE_DEFAULT_DEBUG_CHANNEL(d3dx);
- 
- typedef struct ID3DXMeshImpl
-- 
1.7.3.4

---

From: Natanael Copa <[email-masked]>
Date: Mon, 12 Sep 2011 20:32:37 +0200

On Mon, 12 Sep 2011 05:01:02 -0500

> and wine hasn't put files in /etc for years.

I didn't see you patch til after I had pushed my half-automated upgrade.

I reverted mine and applied yours and bumped pkgrel.
 
> If those should be separate patches, please let me know.

One patch is fine.

> Please CC me on replies, I'm not subscribed to this list.

Thanks alot!

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---