Subject: [alpine-devel] Help with apk error

From: Andrew Bell <[email-masked]>
Date: Tue, 5 Feb 2019 14:20:28 -0500

Hi,

I modified an APKBUILD file for a package.  Now I'm trying to install the
package locally, but I get an error that I don't understand:

$ .s apk add ./gdal-dev-2.4.0-r1.apk
ERROR: unsatisfiable constraints:
  gdal-2.2.3-r1:
    breaks: gdal-dev-2.4.0-r1[gdal=2.4.0-r1]
    satisfies: world[gdal] gdal-dev-2.4.0-r1[gdal]
  gdal-dev-2.4.0-r1:
    masked in: cache
    satisfies: world[gdal-dev><Q1IPps2qjzvYdKJIJI63UPjt8MC4w=]
$ .s apk add ./gdal-2.4.0-r1.apk
ERROR: unsatisfiable constraints:
  gdal-2.4.0-r1:
    masked in: cache
    breaks: gdal-dev-2.2.3-r1[gdal=2.2.3-r1]
    satisfies: world[gdal><Q1G2NpkqhDl2qHuRK7K/sYGLVBR3s=]
               gdal-dev-2.2.3-r1[gdal]

Can someone explain what I'm seeing and how to resolve it?

Thanks,

-- 
Andrew Bell
[email-masked]

---

From: "A. Wilcox" <[email-masked]>
Date: Wed, 6 Feb 2019 02:20:55 -0600

On Feb 5, 2019, at 1:20 PM, Andrew Bell <[email-masked]> wrote:
> 
> Hi,
> 
> I modified an APKBUILD file for a package.  Now I'm trying to install the package locally, but I get an error that I don't understand:
> 

The package and its -dev sub package require their versions to match.  APK’s error messages are woefully confusing in this case.

What you need to do is either uninstall both packages then add the apks manually, or try to add both apks at the same time for upgrade.

—arw

--
A. Wilcox (Sent from my iPhone - not signed)
Project Lead, Adélie Linux
https://adelielinux.org