Subject: [alpine-devel] How to build alpine image from sources

From: Harshal Govind <[email-masked]>
Date: Sun, 25 Feb 2018 12:26:03 -0800

Hi,

I went through the alpine development doc and understood how to build the
individual components and iso image.
To build the iso image i used this command: "sh mkimage.sh --outdir
iso-img/ --arch x86_64 --profile standard"
But this script will fetch the pre-built apk from alpine mirror and build
the image.
Is there any way(script or utility) to build the iso image from sources?

Thanks,
Harshal

---

From: "Tuan M. Hoang" <[email-masked]>
Date: Mon, 26 Feb 2018 23:19:13 -0500

Hi,

If you want to build the ISO, which basically contains a handful of
pre-built packages, from source, you need to build those packages from
source first, then pass --repository with the location containing those
packages to mkimage.sh script.

Tuan,

On 02/25/2018 03:26 PM, Harshal Govind wrote:
> Hi,
> 
> I went through the alpine development doc and understood how to build
> the individual components and iso image. 
> But this script will fetch the pre-built apk from alpine mirror and
> build the image.

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Jakub Jirutka <[email-masked]>
Date: Tue, 27 Feb 2018 09:17:19 +0100

Hi,

you can use https://github.com/alpinelinux/alpine-make-vm-image.

Jakub