Subject: [alpine-devel] Installing vserver

From: Hilco Wijbenga <[email-masked]>
Date: Fri, 6 Jan 2012 00:10:12 -0800

Hi all,

I just tried to follow

http://wiki.alpinelinux.org/wiki/Setting_up_a_basic_vserver

but when I get to the third step and run

/etc/init.d/vprocunhide start

I get

alpine:~$ sudo /etc/init.d/vprocunhide start
Password:
 * Fixing /proc entries visibility ...
/proc/net/: Function not implemented
/proc/net/ip6_flowlabel: Function not implemented
/proc/net/rt6_stats: Function not implemented
:
many more
:
/proc/uptime: Function not implemented
/proc/cmdline: Function not implemented
/proc/version: Function not implemented
 * ERROR: vprocunhide failed to start

I've tried it with alpine-2.3.0-x86_64, alpine-mini-2.3.0-x86_64, and
alpine-2.3.0-x86.

This is on VirtualBox [OS Type: Linux 2.6 (64 bit)] on Gentoo (~x86)
running linux kernel 3.1.6.

Cheers,
Hilco

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Fri, 6 Jan 2012 11:52:59 +0100

On Fri, 6 Jan 2012 00:10:12 -0800

> Hi all,

Hi!
 
> http://wiki.alpinelinux.org/wiki/Setting_up_a_basic_vserver

...
 
> I've tried it with alpine-2.3.0-x86_64, alpine-mini-2.3.0-x86_64, and

Those have all the wrong kernel. Try alpine-vserver iso images listed
to the right: http://alpinelinux.org/downloads

-nc

---

---

From: Hilco Wijbenga <[email-masked]>
Date: Fri, 6 Jan 2012 09:42:35 -0800

> to the right: http://alpinelinux.org/downloads

Silly me. I thought those were for the actual vservers. Which doesn't
make any sense because the vservers "reuse" the "real" server's
kernel.

Sigh ... I guess that's what happens when quickly trying things late
at night. :-)

---

---

From: Natanael Copa <[email-masked]>
Date: Tue, 10 Jan 2012 08:50:37 +0100

On Fri, 6 Jan 2012 09:42:35 -0800
Hilco Wijbenga <[email-masked]> wrote:

> >> I've tried it with alpine-2.3.0-x86_64, alpine-mini-2.3.0-x86_64,
> >> and alpine-2.3.0-x86.
> >
> > Those have all the wrong kernel. Try alpine-vserver iso images
> > listed to the right: http://alpinelinux.org/downloads
> 

We should be more clear on what the different ISOs are for.

I bet I would have done the same.

-nc

---