1

[alpine-devel] Xorg problems

Jeff Pohlmeyer
Details
Message ID
<CAEuRe+2Qgdp5sKywpCOOFgm38s9ET8ASFBX8-hKMukmTb0UAAg@mail.gmail.com>
Sender timestamp
1427221490
DKIM signature
missing
Download raw message
Trying to get Alpine/Xorg up and running on one of these:
  http://www.parkytowers.me.uk/thin/DT166/index.shtml

So far, no luck...


Xfbdev gives a nice display with the lxfb kernel module, but no keyboard:

Xfbdev with -keybd keyboard:
  "Error: Couldn't find keyboard driver keyboard"

Xfbdev with -keybd evdev:
  "Error: Couldn't find keyboard driver evdev"

Adding --enable-kdrive-kbd to the APKBUILD makes the first error go away, but
results in an empty keymap due to an #if 0 defined around some broken code
in ./hw/kdrive/linux/keyboard.c
(Every keypress prints an "Invalid scan code" error to the console.)

There is also an --enable-kdrive-evdev option, but I was really hoping
to avoid udev if at all possible.



So I tried the "real" xorg-server, but...

Xorg with xf86-video-fbdev fails at runtime:
 Assertion failed: key->initialized (../include/privates.h:
dixGetPrivateAddr: 122)

Xorg with xf86-video-vesa fails at runtime:
  VESA(0): Cannot read int vect


There is also a specific "xf86-video-geode" driver for this chipset, I
was able to
compile it with -DVIDMEM_FRAMEBUFFER=0x01, but it still won't load because of a
missing (obsolete?) xf86UnMapVidMem function.


Any hints/suggestions would be appreciated!

Thanks,

 - Jeff


---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---

[alpine-devel] Re: Xorg problems

Jeff Pohlmeyer
Details
Message ID
<CAEuRe+3qyBwdM6MsV7dKPAh7p=Kp-pZ+y5yyB-uNKdu2+KuLpQ@mail.gmail.com>
In-Reply-To
<CAEuRe+2Qgdp5sKywpCOOFgm38s9ET8ASFBX8-hKMukmTb0UAAg@mail.gmail.com> (view parent)
Sender timestamp
1427249429
DKIM signature
missing
Download raw message
On Tue, Mar 24, 2015 at 1:24 PM, Jeff Pohlmeyer wrote:

> Trying to get Alpine/Xorg up and running on one of these:
>   http://www.parkytowers.me.uk/thin/DT166/index.shtml
> ...
> There is also a specific "xf86-video-geode" driver for this chipset,
> but it won't load because of a missing (obsolete?) xf86UnMapVidMem function.


I found a patch for the xf86-video-geode driver:
  http://blog.gmane.org/gmane.comp.freedesktop.xorg.drivers.geode/month=20150301

Happy to report, the video (and keyboard) on my $15 (USD) ebay special
are working now. :-)


Still, the xf86-video-vesa and xf86-video-fbdev are failing on every
machine I've tried.


 - Jeff


---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---