Subject: [alpine-devel] How to create a tun interface?

From: alex M <[email-masked]>
Date: Thu, 13 Dec 2012 05:58:56 +0100

Hello,

I'd like to know how to create a tun interface with AlpineLinux?

I didn't see any uml-utilities or tunctl package and iproute2 seems to
be not build with tuntap support. I don't know if it can work with
Alpine.

Thanks in advance,

Regards.

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Timo Teras <[email-masked]>
Date: Thu, 13 Dec 2012 13:36:39 +0200

> be not build with tuntap support. I don't know if it can work with

iproute2 should be built with tuntap. Maybe you have not installed
iproute2 but are using the 'ip' from busybox builtins?

Try 'apk add iproute2'

- Timo

---

---

From: Natanael Copa <[email-masked]>
Date: Thu, 13 Dec 2012 13:37:34 +0100

On Thu, 13 Dec 2012 13:36:39 +0200

> iproute2 but are using the 'ip' from busybox builtins?

You can also use vde_tunctl from vde2 package or openvpn --mktun.

-nc

---