Subject: [alpine-devel] Alpine as a VirtualBox host

From: qnx4ever <[email-masked]>
Date: Thu, 19 Jan 2012 21:19:43 +0400

Hello Everyone !
Did anyone tried to compile VBox host to run under Alpine (at least in
the HeadLess mode) ?

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Thu, 19 Jan 2012 22:44:41 +0100

On Thu, 19 Jan 2012 21:19:43 +0400

> Did anyone tried to compile VBox host to run under Alpine (at least in

I started with it some time ago.

...
Checking for bcc: found version 0.16.18, OK.
Checking for iasl: found version 20111123, OK.
Checking for xslt: found, OK.
Checking for pthread: found, OK.
./configure: line
2549: /home/ncopa/aports/wip/virtualbox/src/VirtualBox-4.1.6_OSE/kBuild/bin/linux.x86/kmk_sed:
not found Checking for libxml2: ./configure: line
2550: /home/ncopa/aports/wip/virtualbox/src/VirtualBox-4.1.6_OSE/kBuild/bin/linux.x86/kmk_sed:
not found

$ readelf -d /home/ncopa/aports/wip/virtualbox/src/
VirtualBox-4.1.6_OSE/kBuild/bin/linux.x86/kmk_sed

Dynamic section at offset 0x19a10 contains 21 entries:
  Tag        Type                         Name/Value
 0x00000001 (NEEDED)                     Shared library: [librt.so.1]
 0x00000001 (NEEDED)                     Shared library: [libc.so.6]
 0x0000000c (INIT)                       0x80491c0
...

Seems like configure script needs glibc to run its own versions of sed
and other tools. They could at least have shipped statically linked
bins.

oh well...

-nc

---

---

From: Natanael Copa <[email-masked]>
Date: Thu, 19 Jan 2012 23:07:32 +0100

On Thu, 19 Jan 2012 22:44:41 +0100
Natanael Copa <[email-masked]> wrote:

> > Did anyone tried to compile VBox host to run under Alpine (at least
> > in the HeadLess mode) ?
> 
...
> and other tools. They could at least have shipped statically linked

Looking at the gentoo ebuild, it seems like it should be possible to
work around that by using a separate package named kbuild. I think we
can make this beast run.

-nc

---